summaryrefslogtreecommitdiff
path: root/net-analyzer/ndoutils/ndoutils-2.1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /net-analyzer/ndoutils/ndoutils-2.1.3-r1.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'net-analyzer/ndoutils/ndoutils-2.1.3-r1.ebuild')
-rw-r--r--net-analyzer/ndoutils/ndoutils-2.1.3-r1.ebuild95
1 files changed, 95 insertions, 0 deletions
diff --git a/net-analyzer/ndoutils/ndoutils-2.1.3-r1.ebuild b/net-analyzer/ndoutils/ndoutils-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..57a0389779bc
--- /dev/null
+++ b/net-analyzer/ndoutils/ndoutils-2.1.3-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit systemd
+
+DESCRIPTION="Nagios addon to store Nagios data in a MySQL database"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="https://github.com/NagiosEnterprises/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# We require the "nagios" user from net-analyzer/nagios-core at build
+# time.
+DEPEND="dev-db/mysql-connector-c
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ >=net-analyzer/nagios-core-4"
+RDEPEND="${DEPEND}
+ virtual/mysql"
+
+S="${WORKDIR}/${PN}-${P}"
+
+DOCS=(
+ Changelog
+ README
+ THANKS
+ TODO
+ UPGRADING
+ "docs/NDOUTILS DB Model.pdf"
+ "docs/NDOUtils Documentation.pdf"
+)
+
+PATCHES=(
+ "${FILESDIR}/format-security.patch"
+ "${FILESDIR}/ndoutils-2.0.0-asprintf.patch"
+ "${FILESDIR}/sample-config-piddir.patch"
+ "${FILESDIR}/openrc-init.patch"
+)
+
+src_configure() {
+ # The localstatedir is where our socket will be created by the
+ # nagios daemon, so we put it in /var/nagios where the "nagios" user
+ # will be able to write.
+ #
+ # And normally, we would use /run for the pid file, but the daemon
+ # drops permissions before creating it, the the piddir also needs
+ # to be writable by the nagios user.
+ econf --enable-mysql \
+ --localstatedir=/var/nagios \
+ --sysconfdir=/etc/nagios \
+ --with-piddir=/var/nagios
+}
+
+src_compile() {
+ # Avoid "emake all" so that we don't build the stuff for nagios-2.x
+ # and nagios-3.x, some of which throws QA warnings. We don't use it
+ # anyway.
+ pushd src
+ emake file2sock log2ndo ndo2db-4x ndomod-4x.o sockdebug
+ popd
+}
+
+src_install() {
+ default
+ insinto /etc/nagios
+ newins config/ndo2db.cfg-sample ndo2db.cfg
+ newins config/ndomod.cfg-sample ndomod.cfg
+ newinitd "startup/openrc-init" ndo2db
+ newconfd "startup/openrc-conf" ndo2db
+ systemd_newunit "startup/default-service" "${PN}.service"
+
+ # The documentation isn't installed by the build system
+ dodoc -r docs/html
+
+ insinto "/usr/share/${PN}"
+ doins -r db
+
+ # These need to be executable...
+ exeinto "/usr/share/${PN}/db"
+ doexe db/{installdb,prepsql,upgradedb}
+
+ # Use symlinks because the installdb/upgradedb scripts use relative
+ # paths to the SQL queries.
+ dosym "../share/${PN}/db/installdb" /usr/bin/ndoutils-installdb
+ dosym "../share/${PN}/db/upgradedb" /usr/bin/ndoutils-upgradedb
+}
+
+pkg_postinst() {
+ elog "To include NDO in your Nagios setup, you'll need to activate"
+ elog "the NDO broker module in /etc/nagios/nagios.cfg:"
+ elog " broker_module=/usr/bin/ndomod.o config_file=/etc/nagios/ndomod.cfg"
+}