summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 20:10:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 20:10:31 +0100
commit944b3df0f275eea0fd7808913d72a0b280df0c33 (patch)
treeec33697fafd5ce7028b7619baef7a6d27bb74362 /net-analyzer/nagios-plugins
parent7e17b5aabc330abb894f2b90bef0e3fcbcd180d2 (diff)
gentoo auto-resync : 06:08:2022 - 20:10:30
Diffstat (limited to 'net-analyzer/nagios-plugins')
-rw-r--r--net-analyzer/nagios-plugins/Manifest1
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-2.4.0-r1.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins/Manifest b/net-analyzer/nagios-plugins/Manifest
index 7cf0223defdd..2ee57e755455 100644
--- a/net-analyzer/nagios-plugins/Manifest
+++ b/net-analyzer/nagios-plugins/Manifest
@@ -5,5 +5,6 @@ DIST nagios-plugins-2.3.3.tar.gz 2782610 BLAKE2B f02ded0ed6d5c649a82fe7fe06e393b
DIST nagios-plugins-2.4.0.tar.gz 2738643 BLAKE2B 695c3804aec592dad0ae1f2f19222a5ae066944de4169beba08dd1e7beee51c5082679dfc1cf5adc052758e3142f33187ebde9636af19ae313f1448867764878 SHA512 f6f4cd604d28161f36c1429dbfa8f07e9fa468d8d8c21925d53d7049f0765504cb785e1f1189a0c93aa1f0cd1fe3985409c420b7724aa39790836af5c3f725ff
EBUILD nagios-plugins-2.3.1-r3.ebuild 2993 BLAKE2B fdfb49d287611867610decf2de17b1fcc6e070e72d32013979ca33af5279db41b998fe54c894aeceb11dc85e0c672cfc392355533a8c61bef8be91c40eac45f3 SHA512 8e57455884815ea28dc671bb35b5d580f79c5108d5ef0e486493ca2a11886ac4fb19b7e2ffdbba544cbffc073c58f5224a0b144039d3d7496c45cf8139519329
EBUILD nagios-plugins-2.3.3-r3.ebuild 3043 BLAKE2B 81cd85e2d642195e6d02085d3758f1a39faa4fc6676c4788fb03941dbbdfc34f0c0620c47af5a3e62bf3bc693a40c5899106b6fbda0e6e2c457df9cae8fd94b2 SHA512 52f64e344951a83aff641586918279114b7f0e67d1510f02dda463ec224eefa0711b1c2b29a6d87a8e455ccdcae48f31aea1eb6f3d9e017db827a6be2db0061d
+EBUILD nagios-plugins-2.4.0-r1.ebuild 3225 BLAKE2B dda29986ebcc2340c6a1c45805ce47b2e0e3218fdcb562d03be4f06c20c26e54328ff07dc3c7e17e2467c699598e7d1b9a3e511af3b52f8ef7e88d94044aef82 SHA512 67d45f7e9cb6332a975694c3c9fd658c47667b439f7d064310e9c2d2a705d30a436ebe50efcb23c78bc1253463270d253085b97bb45cfce3426f00e5452f61b4
EBUILD nagios-plugins-2.4.0.ebuild 3025 BLAKE2B 87742d9836160af12e2456e51139b7fe1a77f4a7ef6bd5b57044820242d691c353a410c82c0f06368656413d3f7738da70e87f341fae485980f383884b501ad7 SHA512 f8f0eba9e4f4995fc8f3985b7a2ee2e96f2d81cbf3340089e9a3ebdd2c714301249592f46bbfac4d73863b14a74669c940123cfdf56c6cfadfeba8d6036dac9f
MISC metadata.xml 1431 BLAKE2B 7a5b71bb1d5acc47492a8ac0414c5de789e2fff607a1602c8e464dd4285adb1acd71f152dc9dae18bade31623d78ca2ebe796b871f62542d2d29a75a3b5e4ce6 SHA512 5aa293f0fd8f810b3b750772e260009cbf10bb68aae1f8cbb9e02f7565204f8ae14da3f6a18db58e9fdff5fd97ba8566d07a421ff8bc35f07747338ced13b92c
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-2.4.0-r1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..732d59f1bb73
--- /dev/null
+++ b/net-analyzer/nagios-plugins/nagios-plugins-2.4.0-r1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Official plugins for Nagios"
+HOMEPAGE="https://nagios-plugins.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 ldap mysql nagios-dns nagios-ping nagios-game postgres radius samba selinux snmp ssh +ssl"
+
+# Most of the plugins use automagic dependencies, i.e. the plugin will
+# get built if the binary it uses is installed. For example, check_snmp
+# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
+# installed. End result: most of our runtime dependencies are required
+# at build time as well.
+AUTOMAGIC_DEPEND="
+ nagios-dns? ( net-dns/bind-tools )
+ nagios-game? ( games-util/qstat )
+ nagios-ping? ( net-analyzer/fping )
+ samba? ( net-fs/samba )
+ ssh? ( net-misc/openssh )
+ snmp? ( dev-perl/Net-SNMP
+ net-analyzer/net-snmp[-minimal] )"
+
+# Perl really needs to run during the build...
+BDEPEND="${AUTOMAGIC_DEPEND}
+ dev-lang/perl"
+
+DEPEND="
+ ldap? ( net-nds/openldap:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:* )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+ radius? ( net-dialup/freeradius-client )"
+
+# Basically everything in net-analyzer/monitoring-plugins collides with
+# nagios-plugins. Perl (from BDEPEND) is needed at runtime, too.
+RDEPEND="${BDEPEND}
+ ${DEPEND}
+ !net-analyzer/monitoring-plugins
+ selinux? ( sec-policy/selinux-nagios )"
+
+# At least one test is interactive.
+RESTRICT="test"
+
+DOCS=(
+ ACKNOWLEDGEMENTS
+ AUTHORS
+ CODING
+ ChangeLog
+ FAQ
+ NEWS
+ README
+ REQUIREMENTS
+ SUPPORT
+ THANKS
+)
+
+PATCHES=(
+ "${FILESDIR}/define-own-mysql-port-constant.patch"
+)
+
+src_prepare() {
+ default
+
+ # Fix the path to our perl interpreter
+ sed -i -e "1s:/usr/local/bin/perl:/usr/bin/perl:" \
+ "${S}"/plugins-scripts/*.pl \
+ || die 'failed to fix perl interpreter path'
+}
+
+src_configure() {
+ # Disable -fstrict-aliasing until check_ntp can be fixed,
+ # https://github.com/nagios-plugins/nagios-plugins/issues/665
+ append-cflags $(test-flags-CC -fno-strict-aliasing)
+
+ # Use an array to prevent econf from mangling the ping args.
+ local myconf=()
+
+ if use ssl; then
+ myconf+=( $(use_with ssl openssl /usr) )
+ else
+ myconf+=( --without-openssl )
+ myconf+=( --without-gnutls )
+ fi
+
+ # The autodetection for these two commands can hang if localhost is
+ # down or ICMP traffic is filtered. Bug #468296.
+ myconf+=( --with-ping-command="/bin/ping -n -U -w %d -c %d %s" )
+
+ if use ipv6; then
+ myconf+=( --with-ping6-command="/bin/ping6 -n -U -w %d -c %d %s" )
+ fi
+
+ econf \
+ $(use_with mysql) \
+ $(use_with ipv6) \
+ $(use_with ldap) \
+ $(use_with postgres pgsql /usr) \
+ $(use_with radius) \
+ "${myconf[@]}" \
+ --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
+ --sysconfdir="/etc/nagios"
+}
+
+pkg_postinst() {
+ elog "This ebuild has a number of USE flags that determine what you"
+ elog "are able to monitor. Depending on what you want to monitor, some"
+ elog "or all of these USE flags need to be set."
+ elog
+ elog "The plugins are installed in ${ROOT}/usr/$(get_libdir)/nagios/plugins"
+}