summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /net-analyzer/nagios-plugins
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'net-analyzer/nagios-plugins')
-rw-r--r--net-analyzer/nagios-plugins/Manifest2
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-2.3.3.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins/Manifest b/net-analyzer/nagios-plugins/Manifest
index 12f35d9f9081..353b9a9f77aa 100644
--- a/net-analyzer/nagios-plugins/Manifest
+++ b/net-analyzer/nagios-plugins/Manifest
@@ -1,4 +1,6 @@
AUX define-own-mysql-port-constant.patch 3271 BLAKE2B a9776567af41b106616c10aac02042147d162a452e17480433a8fd8ffcf3ce506d6930215e8a8eaa219d7811adffbcc2b3ee6a004661ca2a1f8bdc3339bf3526 SHA512 18cb9be96b3e39a07eeb1cf6bccbbe26766ac355f4822c132253e25a6909c418071c2dc546fb60c055b78f620180035e57436a8ebb771ae1096b78d2e1c7c6ec
DIST nagios-plugins-2.3.1.tar.gz 2833267 BLAKE2B f89eda7a29558dd33dedbf0de150b6a13ba66d213d74041d9eb8c680880b3825bcc9312d251d22f3b483a14c0de7c59d7801954e7563c16352bfc38236676863 SHA512 89208f211e51db4e0d56725a6ff6d2fcf4eb2207f877a2b8f130cda8480a70f318eceb94140eb4f2a17fe3dd967bb3615ccc366c1a531ebd4ff0a04b60c61b8a
+DIST nagios-plugins-2.3.3.tar.gz 2782610 BLAKE2B f02ded0ed6d5c649a82fe7fe06e393b404fc6e9a260365b128c114381d411d93c8980fee6da73c4d03ab73669d5b8754225ff5aa14ef4430ee0c91d8c56cb131 SHA512 2128601b1098eb82f4e7d720b96a5f92d6ad75dc181a94b25c38172767de8b72f9fece3eddb74933b1cd520928ae9416a7dc665e2f059bfe362dd74041d28cd7
EBUILD nagios-plugins-2.3.1-r1.ebuild 3045 BLAKE2B 1c58e0ad3b9d0fe3edc6fc756284aaec94488f67fedc88149ec1154ff6b488f737ccff6dd59a3c653d16e0e41c75e45f305d4236f27bd7d1da85f01608a4c774 SHA512 c700e8d891c208fc3129ebae102896a9c3db025cf4661bdf4541679f4cc646276531fd569614a42d13c02c16e42470d3f3d75d08e281b730dab3ad4b726a9f23
+EBUILD nagios-plugins-2.3.3.ebuild 3050 BLAKE2B 95b01a32fb43ba75778cd2238610b7fe8db07f403e3e1bb6ac9a1b103678003cbe102cfa16486e3e345cc67d7f9a009140056f250839f943e5ff68bfe4547ca1 SHA512 e3a2f79297cb1be3735fe20c47a5c9ea338bc3df0ef702988f767127abdbce9d8ae4628ae45de5b98305e6c4bf1b1aa07f76344a82ddba0205f8c56531b699f7
MISC metadata.xml 1430 BLAKE2B 63a889dc51085a41a5dec4b6c32e6262ff59fdb1413699736d6332a75406749551b1c82d62a2662f4d7935c46a4bc3b51e0ca7e3b070656163fb0b6fc69c742e SHA512 d6cbc6820de52e1ed471b97a6c592af72474db492204594314eebb656b8abe89a01667a7bbb621418fd393aeacb28e9a10c5749de7ace67dd15119f701019e72
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-2.3.3.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-2.3.3.ebuild
new file mode 100644
index 000000000000..71a334434d72
--- /dev/null
+++ b/net-analyzer/nagios-plugins/nagios-plugins-2.3.3.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Official plugins for Nagios"
+HOMEPAGE="http://nagios-plugins.org/"
+SRC_URI="http://nagios-plugins.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 ldap libressl mysql nagios-dns nagios-ping nagios-game postgres radius samba selinux snmp ssh +ssl"
+
+# Most of the plugins use automagic dependencies, i.e. the plugin will
+# get built if the binary it uses is installed. For example, check_snmp
+# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
+# installed. End result: most of our runtime dependencies are required
+# at build time as well.
+AUTOMAGIC_DEPEND="
+ nagios-dns? ( net-dns/bind-tools )
+ nagios-game? ( games-util/qstat )
+ nagios-ping? ( net-analyzer/fping )
+ samba? ( net-fs/samba )
+ ssh? ( net-misc/openssh )
+ snmp? ( dev-perl/Net-SNMP
+ net-analyzer/net-snmp[-minimal] )"
+
+# Perl really needs to run during the build...
+BDEPEND="${AUTOMAGIC_DEPEND}
+ dev-lang/perl"
+
+DEPEND="
+ ldap? ( net-nds/openldap )
+ mysql? ( dev-db/mysql-connector-c )
+ postgres? ( dev-db/postgresql:* )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ radius? ( net-dialup/freeradius-client )"
+
+# Basically everything in net-analyzer/monitoring-plugins collides with
+# nagios-plugins. Perl (from BDEPEND) is needed at runtime, too.
+RDEPEND="${BDEPEND}
+ ${DEPEND}
+ !net-analyzer/monitoring-plugins
+ selinux? ( sec-policy/selinux-nagios )"
+
+# At least one test is interactive.
+RESTRICT="test"
+
+DOCS=(
+ ACKNOWLEDGEMENTS
+ AUTHORS
+ CODING
+ ChangeLog
+ FAQ
+ NEWS
+ README
+ REQUIREMENTS
+ SUPPORT
+ THANKS
+)
+
+PATCHES=( "${FILESDIR}/define-own-mysql-port-constant.patch" )
+
+src_prepare() {
+ default
+
+ # Fix the path to our perl interpreter
+ sed -i -e "1s:/usr/local/bin/perl:/usr/bin/perl:" \
+ "${S}"/plugins-scripts/*.pl \
+ || die 'failed to fix perl interpreter path'
+}
+
+src_configure() {
+ # Use an array to prevent econf from mangling the ping args.
+ local myconf=()
+
+ if use ssl; then
+ myconf+=( $(use_with ssl openssl /usr) )
+ else
+ myconf+=( --without-openssl )
+ myconf+=( --without-gnutls )
+ fi
+
+ # The autodetection for these two commands can hang if localhost is
+ # down or ICMP traffic is filtered. Bug #468296.
+ myconf+=( --with-ping-command="/bin/ping -n -U -w %d -c %d %s" )
+
+ if use ipv6; then
+ myconf+=( --with-ping6-command="/bin/ping6 -n -U -w %d -c %d %s" )
+ fi
+
+ econf \
+ $(use_with mysql) \
+ $(use_with ipv6) \
+ $(use_with ldap) \
+ $(use_with postgres pgsql /usr) \
+ $(use_with radius) \
+ "${myconf[@]}" \
+ --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
+ --sysconfdir="/etc/nagios"
+}
+
+pkg_postinst() {
+ elog "This ebuild has a number of USE flags that determine what you"
+ elog "are able to monitor. Depending on what you want to monitor, some"
+ elog "or all of these USE flags need to be set."
+ elog
+ elog "The plugins are installed in ${ROOT}/usr/$(get_libdir)/nagios/plugins"
+}