summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-plugins-linux-madrisan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /net-analyzer/nagios-plugins-linux-madrisan
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'net-analyzer/nagios-plugins-linux-madrisan')
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/Manifest3
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/files/nagios-plugins-linux-madrisan-25-fix-fno-common.patch37
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-25-r1.ebuild6
3 files changed, 44 insertions, 2 deletions
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/Manifest b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
index 5fddcc204780..ae05508db26b 100644
--- a/net-analyzer/nagios-plugins-linux-madrisan/Manifest
+++ b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
@@ -1,3 +1,4 @@
+AUX nagios-plugins-linux-madrisan-25-fix-fno-common.patch 1276 BLAKE2B 2dbae02f3b64590e091e2f6d4ce8d3462046eec02ed2a1234858e553c862922623fca7a1bc171d3381ac62f6953b9425f1e2a9bee11d8d42759002d9d11da50d SHA512 bc8e3a1870cc327d7519c248f33b4aa20e2689d48e76bffdcb0ca388a85b110d5484b115c78353e3369f0fe2d004325d43299eb1f03973c570de6a8efca2d15c
DIST nagios-plugins-linux-madrisan-25.tar.xz 371712 BLAKE2B 60637426d9ced289a1acdf61c3e7c5a2b3227afb20079ef93d445057b2127d12a6c76ab5a780571ac8bdd6ac3b55de2761722236d2ed7a057ab84559d97610e9 SHA512 64961a16e24802d66c48d0c33bd63d75aba8492f38dd83a57ee2e7cb728cf6876c7869622256c4249a9e9da39b744a332df6ecad80f6039861887bb5c8d806ec
-EBUILD nagios-plugins-linux-madrisan-25-r1.ebuild 1027 BLAKE2B efb8e3ad6283580d948b083c65984d9dffd338d7e2a2ee8be01b8bd2af578e8afbd457cf61fb61d27472a00519208bf3d9ddf2d6c05e5524f20d3d2b4801c6f7 SHA512 0d55a77d5cfa4d741c6388cf984b8eb376284f35d4f5979a7b326d446e2f48b16d411fdda8b1595b36e0283f1d9a0b13841a4f4824fbe0929cca096b45355766
+EBUILD nagios-plugins-linux-madrisan-25-r1.ebuild 1171 BLAKE2B 7d2ad802b89681b59b38ffb0bf074c75967df6fabe2298fff43a66852f2a7d8d654d2a7b94af1b2ce1c0c69ff8441e236d9379c5b94831d97ab07ee3df17dd0a SHA512 e466b0150c1081a58234091894efa581611b42b44587b5e6efaabbc309300ffb4ce05f1c8522ba65ffc6c930657e548210c03821779ba013404be1258f19ff8e
MISC metadata.xml 517 BLAKE2B b78b662d5028f2d3a6739be37b771af2ee51c35fa47b9aeff228dbcf67a8feaee45ea8db57acf2c6ac490b19ec87f97d0ba4db2883406945f5e37d30e430921e SHA512 b3a1dfedeb45883a101e1194643a6cfbc5041cf772f9ac70d32de38d909ef5aa5a1403b283e797c721b663498953d4b0810887a4c3e2ab51655084122b2e7ce3
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/files/nagios-plugins-linux-madrisan-25-fix-fno-common.patch b/net-analyzer/nagios-plugins-linux-madrisan/files/nagios-plugins-linux-madrisan-25-fix-fno-common.patch
new file mode 100644
index 000000000000..74bddd66e749
--- /dev/null
+++ b/net-analyzer/nagios-plugins-linux-madrisan/files/nagios-plugins-linux-madrisan-25-fix-fno-common.patch
@@ -0,0 +1,37 @@
+From 4936ca25f3e9a2875ce063033e5e8f3a3590dab2 Mon Sep 17 00:00:00 2001
+From: Davide Madrisan <davide.madrisan@gmail.com>
+Date: Mon, 27 Jan 2020 22:00:41 +0100
+Subject: [PATCH] The build fails when '-fno-common' is added to CFLAGS
+
+As reported by 'sbraz', the build stops with the error message:
+
+ (.bss+0x8): multiple definition of `program_name'
+ (.bss+0x0): multiple definition of `program_name_short'
+
+This flag will be apparently enabled by default in gcc 10.
+
+Fix this build problem by correctly referencing as extern both
+the variables in the header file.
+
+Signed-off-by: Davide Madrisan <davide.madrisan@gmail.com>
+---
+ include/progname.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/progname.h b/include/progname.h
+index 576ed16..847122a 100644
+--- a/include/progname.h
++++ b/include/progname.h
+@@ -25,10 +25,10 @@ extern "C" {
+ #endif
+
+ /* String containing name the program is called with. */
+- const char *program_name;
++ extern const char *program_name;
+
+ /* String containing a short version of 'program_name'. */
+- const char *program_name_short;
++ extern const char *program_name_short;
+
+ /* Set program_name, based on argv[0].
+ argv0 must be a string allocated with indefinite extent, and must not be
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-25-r1.ebuild b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-25-r1.ebuild
index 6367fdc2f4e7..284d0d9d1a83 100644
--- a/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-25-r1.ebuild
+++ b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-25-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,10 @@ IUSE="curl"
DEPEND="curl? ( net-misc/curl:0= )"
RDEPEND="${DEPEND}"
+# https://github.com/madrisan/nagios-plugins-linux/issues/48
+# Will be in the next release
+PATCHES=( "${FILESDIR}/${P}-fix-fno-common.patch" )
+
S="${WORKDIR}/${MY_P}"
src_prepare() {