summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20191028.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20191028.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20191028.ebuild')
-rw-r--r--net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20191028.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20191028.ebuild b/net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20191028.ebuild
new file mode 100644
index 000000000000..cd457b7e25dc
--- /dev/null
+++ b/net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20191028.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module vcs-snapshot
+
+MY_PN="${PN/nagios-plugin-/}"
+MY_COMMIT="80db8aa58be8f5d7800564d62305281be1ec8e6b"
+
+DESCRIPTION="Nagios plugin to monitor the values of onboard sensors and disk temperatures"
+HOMEPAGE="https://github.com/matteocorti/check_lm_sensors"
+SRC_URI="https://github.com/matteocorti/${MY_PN}/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-perl/Module-Install"
+RDEPEND="
+ dev-perl/JSON-MaybeXS
+ dev-perl/Monitoring-Plugin
+ virtual/perl-Getopt-Long
+"
+
+src_compile() {
+ default
+ pod2man ${MY_PN}.pod > ${MY_PN}.1 || die
+}
+
+src_install() {
+ perl-module_src_install
+ doman ${MY_PN}.1
+ local plugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${plugindir}"
+ mv "${ED}/usr/bin/${MY_PN}" "${ED}/${plugindir}" || die
+}