summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-icinga-openvpn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-25 21:55:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-25 21:55:01 +0000
commitef596bcaa32d9c69d88a3451193cb242da803db1 (patch)
treed6084e886d9fb2f2bd064f937c0257aa1dfea7a6 /net-analyzer/nagios-icinga-openvpn
parent83ebb477861172671f6796999e016400b659d65f (diff)
gentoo auto-resync : 25:02:2023 - 21:55:01
Diffstat (limited to 'net-analyzer/nagios-icinga-openvpn')
-rw-r--r--net-analyzer/nagios-icinga-openvpn/Manifest3
-rw-r--r--net-analyzer/nagios-icinga-openvpn/metadata.xml3
-rw-r--r--net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r3.ebuild38
3 files changed, 43 insertions, 1 deletions
diff --git a/net-analyzer/nagios-icinga-openvpn/Manifest b/net-analyzer/nagios-icinga-openvpn/Manifest
index aca6b397b1f1..ea6dd5a30dc2 100644
--- a/net-analyzer/nagios-icinga-openvpn/Manifest
+++ b/net-analyzer/nagios-icinga-openvpn/Manifest
@@ -1,3 +1,4 @@
DIST nagios-icinga-openvpn-0.0.1.tar.gz 4637 BLAKE2B 365b6450cccd5f7f25348583eae45c0b15932ec1e858d375171911e4108dd2b7fc133559a35399ece8d2a349f05b2f51897cf9e271f498b6bbaa2c6bba3551a9 SHA512 0dae6c2df71a20e287720767aa4ba41d0568f3cd4bd2a6eb252f86d810d3de265ddc38397df15bb1b115ba35ac68aa6e18345dc4432d4d13b08b500483ffbb11
EBUILD nagios-icinga-openvpn-0.0.1-r2.ebuild 1201 BLAKE2B 4870e01efff48b49dfbf4d6cd33f9805e27c25a84c6c6a70594430a5ef30531d4b6ce4b3c1644d7d76473ec7b355c80dd5535c5d0b560029ed1309beecf569dc SHA512 f45e1bc2d409c24696ee3330aded8989f824e1b27c52cbaee687b55d11c454bbc80158fe7d4af2f51cc499257ae88cfacd7a9e6ed64794f03305226ddcc0ab8d
-MISC metadata.xml 253 BLAKE2B 63a51cab94d3e978d2c7dd1d124efd1c9e11c5ae277806a1f12359b2db370c37382fc1947e85940f6b0a439e3d49eecdd8d9bfb96587352d6a83803d2fd40bb6 SHA512 8da7cfe0cd26a54c106f2c029bbde93abf77576835e4fa66bc538dcf12fd41160f7cc2dd843a221962bb9a6f965311c076a1557caa38d503f371569b84841e33
+EBUILD nagios-icinga-openvpn-0.0.1-r3.ebuild 1217 BLAKE2B f6023bf507b282f11e7d0e5ecc66717660b8887fef450876b18aec5dfb24851628110360337406afa8d51c42f0290216b8fea0521429997a84d9201e86651055 SHA512 3c7c823ea52f00012dd251b06797fb1df824b2468ab0229c4a855a85db550a5134ce27ea5cbcb419236661993ed22ed1bf1a0c77bccbddf39948433197fb765a
+MISC metadata.xml 352 BLAKE2B dd1dd8a4b5a742cd5e7ec46a22748f01d56ce26fa0d3d1a855bf0699db64cd5fa181306ac9528991572906ac89c6125bf6d10e97332bc148996cac14f5cf83d5 SHA512 3930012be14153b9cba53af2fc2edce373e1a279a5364c3cebcc472dfdbd7f544205145e842630da210b75d6c8cd34d9bb6b91403ed1a51e4b5c99061c31e1ca
diff --git a/net-analyzer/nagios-icinga-openvpn/metadata.xml b/net-analyzer/nagios-icinga-openvpn/metadata.xml
index f2908ee10b59..e8fbfcfe3519 100644
--- a/net-analyzer/nagios-icinga-openvpn/metadata.xml
+++ b/net-analyzer/nagios-icinga-openvpn/metadata.xml
@@ -5,4 +5,7 @@
<email>mjo@gentoo.org</email>
<name>Michael Orlitzky</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">liquidat/nagios-icinga-openvpn</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r3.ebuild b/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r3.ebuild
new file mode 100644
index 000000000000..29bd4732ec09
--- /dev/null
+++ b/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_9 python3_10 python3_11 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+MY_PN="check_openvpn"
+DESCRIPTION="A Nagios plugin to check whether an OpenVPN server is alive"
+HOMEPAGE="https://github.com/liquidat/nagios-icinga-openvpn"
+SRC_URI="https://github.com/liquidat/nagios-icinga-openvpn/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_install() {
+ distutils-r1_src_install
+
+ local nagiosplugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${nagiosplugindir}"
+
+ # Create a symlink from the nagios plugin directory to the /usr/bin
+ # location. The "binary" in /usr/bin should also be a symlink, since
+ # the python machinery allows the user to switch out the
+ # interpreter. We don't want to mess with any of that, so we just
+ # point to whatever the system would use if the user executed
+ # ${MY_PN}.
+ #
+ # The relative symlink is preferred so that if the package is
+ # installed e.g. while in a chroot, the symlink will never point
+ # outside of that chroot.
+ #
+ dosym "../../../bin/${MY_PN}" "${nagiosplugindir}/${MY_PN}"
+}