summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-icinga-openvpn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-01 22:03:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-01 22:03:23 +0100
commit590b9b7b03bf4651e099949e318755af7cfa81b8 (patch)
tree54c184b7d26c25f1922bfeaf19a1dd45a2e3b1eb /net-analyzer/nagios-icinga-openvpn
parentf4fc10428424904caf2035cffc442195cb088b2c (diff)
gentoo resync : 01.08.2021
Diffstat (limited to 'net-analyzer/nagios-icinga-openvpn')
-rw-r--r--net-analyzer/nagios-icinga-openvpn/Manifest1
-rw-r--r--net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/nagios-icinga-openvpn/Manifest b/net-analyzer/nagios-icinga-openvpn/Manifest
index 386b3333cabc..f019798defef 100644
--- a/net-analyzer/nagios-icinga-openvpn/Manifest
+++ b/net-analyzer/nagios-icinga-openvpn/Manifest
@@ -1,3 +1,4 @@
DIST nagios-icinga-openvpn-0.0.1.tar.gz 4637 BLAKE2B 365b6450cccd5f7f25348583eae45c0b15932ec1e858d375171911e4108dd2b7fc133559a35399ece8d2a349f05b2f51897cf9e271f498b6bbaa2c6bba3551a9 SHA512 0dae6c2df71a20e287720767aa4ba41d0568f3cd4bd2a6eb252f86d810d3de265ddc38397df15bb1b115ba35ac68aa6e18345dc4432d4d13b08b500483ffbb11
EBUILD nagios-icinga-openvpn-0.0.1-r1.ebuild 1200 BLAKE2B 7ae3d149997a47dd3958d69346a54488d89212196a8aa8a3de61c83528ac7bcc4bb57696f256d11c6140f0aa195d3f29f5fb5603aee86e9be6b223326724d62b SHA512 32a0c553937548477cdf84e369dffcbea84f2748ad460030687cccd562ee91036b7d8658e37a1858b078405bf6575d9ba3e3c434f070b8d2d3174f01205673c1
+EBUILD nagios-icinga-openvpn-0.0.1-r2.ebuild 1212 BLAKE2B e323ee6bbf7e208dbfe0b32068f78ce36c7b39dec27e692a534ca57eac8cf8f6fb0320827fd2b4c12a6f4e270eeec6902c5049ef452552b7f5085c70d34f6004 SHA512 c15bfb212bcf5e8407e0ba729082e99165aa05fd39e19b6cd1ab8689a9055965223728623f02d1f2bc99562d6cd28bbad50bee241a6eac53b43c49cc8cc5b283
MISC metadata.xml 252 BLAKE2B fa9e1dbdc0de3313b50ecd9de7ac59006074b8b75ecb97a8fc4de5fb14609cb00dc1b24ba95a2e7fb11cbc6f8c8f0c068bd0311713cc2aa7e6016992dbd6e8bd SHA512 92f660063c96ac5b3e24e58733006d4a72a7e2f41605988efb575546a2539a92b1ceb3a37e018fcb5c08264a42af26950d6520ea80ba60130ad25ce6092ce742
diff --git a/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r2.ebuild b/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r2.ebuild
new file mode 100644
index 000000000000..6ff5f2740438
--- /dev/null
+++ b/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_8 python3_9 python3_10 )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+MY_PN="check_openvpn"
+DESCRIPTION="A Nagios plugin to check whether an OpenVPN server is alive"
+HOMEPAGE="https://github.com/liquidat/nagios-icinga-openvpn"
+SRC_URI="https://github.com/liquidat/nagios-icinga-openvpn/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_install() {
+ distutils-r1_src_install
+
+ local nagiosplugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${nagiosplugindir}"
+
+ # Create a symlink from the nagios plugin directory to the /usr/bin
+ # location. The "binary" in /usr/bin should also be a symlink, since
+ # the python machinery allows the user to switch out the
+ # interpreter. We don't want to mess with any of that, so we just
+ # point to whatever the system would use if the user executed
+ # ${MY_PN}.
+ #
+ # The relative symlink is preferred so that if the package is
+ # installed e.g. while in a chroot, the symlink will never point
+ # outside of that chroot.
+ #
+ dosym "../../../bin/${MY_PN}" "${nagiosplugindir}/${MY_PN}"
+}