summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-icinga-openvpn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /net-analyzer/nagios-icinga-openvpn
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'net-analyzer/nagios-icinga-openvpn')
-rw-r--r--net-analyzer/nagios-icinga-openvpn/Manifest1
-rw-r--r--net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/nagios-icinga-openvpn/Manifest b/net-analyzer/nagios-icinga-openvpn/Manifest
index 9d77e31b4eb0..64180b42e011 100644
--- a/net-analyzer/nagios-icinga-openvpn/Manifest
+++ b/net-analyzer/nagios-icinga-openvpn/Manifest
@@ -1,3 +1,4 @@
DIST nagios-icinga-openvpn-0.0.1.tar.gz 4637 BLAKE2B 365b6450cccd5f7f25348583eae45c0b15932ec1e858d375171911e4108dd2b7fc133559a35399ece8d2a349f05b2f51897cf9e271f498b6bbaa2c6bba3551a9 SHA512 0dae6c2df71a20e287720767aa4ba41d0568f3cd4bd2a6eb252f86d810d3de265ddc38397df15bb1b115ba35ac68aa6e18345dc4432d4d13b08b500483ffbb11
+EBUILD nagios-icinga-openvpn-0.0.1-r1.ebuild 1211 BLAKE2B 2f8b54e651dff1f97a3477780c81c18b3b281e071fa58ba24431ad9593d0adcdf97426a3da0dc440db716fe77035bdf7264af3f3048f083121efa210bd34ad05 SHA512 67721746b526b8cc6d455dff3cbea3ef3934aca703b4c0ea54f48dc49bd5495a5a5ebe2cd5e1a5e96154d1978a2a1ebc1c3579036afc723ed42bab554a8b5cde
EBUILD nagios-icinga-openvpn-0.0.1.ebuild 1162 BLAKE2B be2394d2b19d71161884a8964831f4fa4a788aaa8b5be3b4ca0183be8b70bdadec2b9ac45e637356abfd4f550de40eec5286ab4363d68983e74c5d2f0280ac77 SHA512 1d50e156fe83cd9c6e5379c8352ea110be11548480f73d20cb9519553f1f96f863c2416b92210b7fb6456bba26c46dc443deb0064b66f9aff9de30891331fd66
MISC metadata.xml 252 BLAKE2B fa9e1dbdc0de3313b50ecd9de7ac59006074b8b75ecb97a8fc4de5fb14609cb00dc1b24ba95a2e7fb11cbc6f8c8f0c068bd0311713cc2aa7e6016992dbd6e8bd SHA512 92f660063c96ac5b3e24e58733006d4a72a7e2f41605988efb575546a2539a92b1ceb3a37e018fcb5c08264a42af26950d6520ea80ba60130ad25ce6092ce742
diff --git a/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r1.ebuild b/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..a03ce2d5c4d0
--- /dev/null
+++ b/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+MY_PN="check_openvpn"
+DESCRIPTION="A Nagios plugin to check whether an OpenVPN server is alive"
+HOMEPAGE="https://github.com/liquidat/nagios-icinga-openvpn"
+SRC_URI="https://github.com/liquidat/nagios-icinga-openvpn/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_install() {
+ distutils-r1_src_install
+
+ local nagiosplugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${nagiosplugindir}"
+
+ # Create a symlink from the nagios plugin directory to the /usr/bin
+ # location. The "binary" in /usr/bin should also be a symlink, since
+ # the python machinery allows the user to switch out the
+ # interpreter. We don't want to mess with any of that, so we just
+ # point to whatever the system would use if the user executed
+ # ${MY_PN}.
+ #
+ # The relative symlink is preferred so that if the package is
+ # installed e.g. while in a chroot, the symlink will never point
+ # outside of that chroot.
+ #
+ dosym "../../../bin/${MY_PN}" "${nagiosplugindir}/${MY_PN}"
+}