summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-check_multiple
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-analyzer/nagios-check_multiple
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-analyzer/nagios-check_multiple')
-rw-r--r--net-analyzer/nagios-check_multiple/Manifest3
-rw-r--r--net-analyzer/nagios-check_multiple/metadata.xml11
-rw-r--r--net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild46
3 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_multiple/Manifest b/net-analyzer/nagios-check_multiple/Manifest
new file mode 100644
index 000000000000..f0e64423ff50
--- /dev/null
+++ b/net-analyzer/nagios-check_multiple/Manifest
@@ -0,0 +1,3 @@
+DIST nagios-check_multiple-0.0.1.tar.gz 9376 BLAKE2B 2db464b7edd4aa704560a3f16a5d70e4cdef7cd35284e3c679f3e10e5ef6eaaba19dc361efbb10a77f87c14726439869e4b415fe7e393a1d7ac23233b3bfa66a SHA512 a75bcd821afc6daca612f42c552fb965a3068dc04a94df41ff41d36928c764d44bcf72e1bd6d776bf4b443c73fc3946c0a91443a562019fcd1b6e8687d0ebcd2
+EBUILD nagios-check_multiple-0.0.1.ebuild 1356 BLAKE2B 2656b3d6558fbbfc33c216e8734ab496d069d59dfb4ceb2b19fbd4fc0bf58a73d1e7ff3d8c896e86aef48eacec653b736c554f9359a4aff4251c79589295417e SHA512 d690763ff2a233ad99209f9df71e3121fa8542cf4692cb48067c2c77341c378767467eafecea994fadccbdd007479d311a9b11a6ae0300349645262abe4f3bac
+MISC metadata.xml 346 BLAKE2B 16270d3fccdcd1c5519beddf3e520377a2538ca793fc1d0c9e3f1e640db66b562971900d5595754104cc30390661c6ff714ac790868e6aeae719e68c72eb2d0d SHA512 7f773b9c98c57e43fb394a2db6bc357d49c4561f44419aff7867fdc07eece455a473309646e90ed065ab11c64576d4dd764d134403330bd83e9f71e680d5a932
diff --git a/net-analyzer/nagios-check_multiple/metadata.xml b/net-analyzer/nagios-check_multiple/metadata.xml
new file mode 100644
index 000000000000..9956f0ad2444
--- /dev/null
+++ b/net-analyzer/nagios-check_multiple/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">clarkbox/check_multiple</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild b/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild
new file mode 100644
index 000000000000..2ab9a4401b09
--- /dev/null
+++ b/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+MY_PN="check_multiple"
+DESCRIPTION="A Nagios plugin to execute multiple checks in parallel"
+HOMEPAGE="https://github.com/clarkbox/${MY_PN}"
+SRC_URI="https://github.com/clarkbox/check_multiple/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+
+ local nagiosplugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${nagiosplugindir}"
+
+ # Create a symlink from the nagios plugin directory to the /usr/bin
+ # location. The "binary" in /usr/bin should also be a symlink, since
+ # the python machinery allows the user to switch out the
+ # interpreter. We don't want to mess with any of that, so we just
+ # point to whatever the system would use if the user executed
+ # ${MY_PN}.
+ #
+ # The relative symlink is preferred so that if the package is
+ # installed e.g. while in a chroot, the symlink will never point
+ # outside of that chroot.
+ #
+ dosym "../../../bin/${MY_PN}" "${nagiosplugindir}/${MY_PN}"
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest -v lib/check_multiple/check_multiple.py \
+ || die "test suite failed"
+}