summaryrefslogtreecommitdiff
path: root/net-analyzer/multimon-ng/multimon-ng-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-19 15:38:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-19 15:38:48 +0100
commit3b882b15eed3bb219b5f340b63733c8cda643079 (patch)
treec84890953bd9a939137323d667a7762da89f0f0c /net-analyzer/multimon-ng/multimon-ng-1.2.0.ebuild
parent4d9aef45678c7cb55b24107642790224ab8c153b (diff)
gentoo auto-resync : 19:08:2023 - 15:38:48
Diffstat (limited to 'net-analyzer/multimon-ng/multimon-ng-1.2.0.ebuild')
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-1.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/multimon-ng/multimon-ng-1.2.0.ebuild b/net-analyzer/multimon-ng/multimon-ng-1.2.0.ebuild
new file mode 100644
index 000000000000..8144bfe94435
--- /dev/null
+++ b/net-analyzer/multimon-ng/multimon-ng-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
+HOMEPAGE="https://github.com/EliasOenal/multimon-ng"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/EliasOenal/multimon-ng.git"
+else
+ SRC_URI="https://github.com/EliasOenal/multimonNG/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pulseaudio X"
+
+DEPEND="pulseaudio? ( media-libs/libpulse )
+ X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}
+ media-sound/sox"
+
+src_prepare() {
+ use pulseaudio || sed -i '/find_package( PulseAudio )/d' CMakeLists.txt
+ use X || sed -i '/find_package( X11 )/d' CMakeLists.txt
+ cmake_src_prepare
+}