summaryrefslogtreecommitdiff
path: root/net-analyzer/multimon-ng/multimon-ng-1.1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-analyzer/multimon-ng/multimon-ng-1.1.9.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-analyzer/multimon-ng/multimon-ng-1.1.9.ebuild')
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-1.1.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/multimon-ng/multimon-ng-1.1.9.ebuild b/net-analyzer/multimon-ng/multimon-ng-1.1.9.ebuild
new file mode 100644
index 000000000000..f2011e9ff0d2
--- /dev/null
+++ b/net-analyzer/multimon-ng/multimon-ng-1.1.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
+HOMEPAGE="https://github.com/EliasOenal/multimon-ng"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/EliasOenal/multimon-ng.git"
+else
+ SRC_URI="https://github.com/EliasOenal/multimonNG/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pulseaudio X"
+
+DEPEND="pulseaudio? ( media-sound/pulseaudio )
+ X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+PDEPEND="media-sound/sox"
+
+src_prepare() {
+ use pulseaudio || sed -i '/find_package( PulseAudio )/d' CMakeLists.txt
+ use X || sed -i '/find_package( X11 )/d' CMakeLists.txt
+ cmake_src_prepare
+}