summaryrefslogtreecommitdiff
path: root/net-analyzer/mtr/mtr-0.94.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /net-analyzer/mtr/mtr-0.94.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'net-analyzer/mtr/mtr-0.94.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-0.94.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-analyzer/mtr/mtr-0.94.ebuild b/net-analyzer/mtr/mtr-0.94.ebuild
index 7f9e0050a0cb..b23e88ccf2cc 100644
--- a/net-analyzer/mtr/mtr-0.94.ebuild
+++ b/net-analyzer/mtr/mtr-0.94.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools bash-completion-r1 fcaps
DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
@@ -10,8 +11,10 @@ SRC_URI="https://github.com/traviscross/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="gtk +ipinfo +ipv6 jansson ncurses"
+# This is an inherited RESTRICT - figure out why!
+RESTRICT="test"
RDEPEND="
gtk? (
@@ -21,18 +24,15 @@ RDEPEND="
jansson? ( dev-libs/jansson )
ncurses? ( sys-libs/ncurses:0= )
"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
DOCS=( AUTHORS FORMATS NEWS README.md SECURITY TODO )
FILECAPS=( cap_net_raw usr/sbin/mtr-packet )
+
PATCHES=(
"${FILESDIR}"/${PN}-0.88-tinfo.patch
)
-RESTRICT="test"
src_prepare() {
default