summaryrefslogtreecommitdiff
path: root/net-analyzer/monitoring-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /net-analyzer/monitoring-plugins
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'net-analyzer/monitoring-plugins')
-rw-r--r--net-analyzer/monitoring-plugins/Manifest2
-rw-r--r--net-analyzer/monitoring-plugins/files/monitoring-plugins-fix-check-disk-on-btrfs.patch20
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1-r1.ebuild108
3 files changed, 130 insertions, 0 deletions
diff --git a/net-analyzer/monitoring-plugins/Manifest b/net-analyzer/monitoring-plugins/Manifest
index 93c75b4b386e..e047cab471cc 100644
--- a/net-analyzer/monitoring-plugins/Manifest
+++ b/net-analyzer/monitoring-plugins/Manifest
@@ -1,4 +1,6 @@
AUX define-own-mysql-port-constant.patch 3296 BLAKE2B 7a7c88c6f2c71bc1fc2f802ad202c2d2dbf3ede5af55dbe46cc15a064d37178b27670e30aa7bea07147456ce4d3e1ce9f495fa6df9deb4095367a7427e217719 SHA512 3ead6340800ac15fbe76e223599a5b3dbc6b6b13b72b684919aa43487838564ad7117b4e67fa7f36f0f58554fd8b8d6233efbcb82e6927a0c31f22c6a9ab5dbb
+AUX monitoring-plugins-fix-check-disk-on-btrfs.patch 913 BLAKE2B 7fb50e4b83a64da3ebfbe94eafcb03ffc39b6ec1440112c7c1e98c9dfb020466dddecee074cf61fbcdacecae58982456bab99d6e1d771148bb6f111ec9db0900 SHA512 8e4ab9eb474413b22a6893bbcab01edd655bf354c263cfba339c37b2c14093ab22aac05d732576266fa3e98880b29473cf5ff29494c54e954215f58a5768409e
DIST monitoring-plugins-2.3.1.tar.gz 2529669 BLAKE2B 8dbbab78c1e57e249024fe57439acb41960585f2cccba20d03ca75a04b87e84752665f49cfe545c6a409d29094077dac0485aef872586f853e2f0f2187bf5070 SHA512 0ae76bc776997ed23d142ad9a688edc4df9b8ec0f9539b446e4fb4849a165cc88e97cbfb3a7a9a450de452e021d38f2e4ada7e8a22d78cf58e17e266472d01d7
+EBUILD monitoring-plugins-2.3.1-r1.ebuild 3047 BLAKE2B 37cf560fc5b8f020cf630d5038616ec7a29e6f4e6154522637aa6c73a6326b553f8e763d0e40279ec7a4f61d0a2675d3ba23b14c8a9f42ab43851067f6bcc7d7 SHA512 268a672ef83c9ddc974430b93ef97c51d47498d84116678eec559098e00456bdabd7b6fb30602f2773e04dbd03fca46c64efbbb85b0350aa1010ef45e4a185e9
EBUILD monitoring-plugins-2.3.1.ebuild 3034 BLAKE2B d9c3b074d9fe133c3cccb3679aac0edff0690fbe5b0f7e67b8b8a232008188ad020fa1f6ddcf753c045ff2d1834f0134c3f3ca2a5856104ac14ba12834c2d026 SHA512 e82fc24872ee362fce26de6836fa912ab0582222c10179d8e159ce678fb0f9455f5b7c5e41a2991711ab6305eaa0a7bebf0cd38926b8fd4ea4cedbe9682fa73d
MISC metadata.xml 1435 BLAKE2B 19cf3223867cee4899e5bdaf33948497c5cd66e94198b6a0c081ea440bf7ecfc7dcf4855b44a7ead5fc983756490f3a79059d51202be9d9f2eea24c6857eb165 SHA512 c781d735ced89fe81d49f400ada6916702ad2825c35c6bb589199902917df415a50335ce058eea45e6eb3fe66813ed2f4009cc6831e15d2b7369fcc12e8c0b26
diff --git a/net-analyzer/monitoring-plugins/files/monitoring-plugins-fix-check-disk-on-btrfs.patch b/net-analyzer/monitoring-plugins/files/monitoring-plugins-fix-check-disk-on-btrfs.patch
new file mode 100644
index 000000000000..cbd458372133
--- /dev/null
+++ b/net-analyzer/monitoring-plugins/files/monitoring-plugins-fix-check-disk-on-btrfs.patch
@@ -0,0 +1,20 @@
+https://bugs.gentoo.org/830249
+https://github.com/monitoring-plugins/monitoring-plugins/issues/1357
+https://github.com/monitoring-plugins/monitoring-plugins/commit/e17c1e9ed95b8b9681dccd5a909ac5a02a04416c
+
+diff --git a/plugins/check_disk.c b/plugins/check_disk.c
+index 844e625f..a2735195 100644
+--- a/plugins/check_disk.c
++++ b/plugins/check_disk.c
+@@ -1068,10 +1068,7 @@ get_stats (struct parameter_list *p, struct fs_usage *fsp) {
+
+ void
+ get_path_stats (struct parameter_list *p, struct fs_usage *fsp) {
+- /* 2007-12-08 - Workaround for Gnulib reporting insanely high available
+- * space on BSD (the actual value should be negative but fsp->fsu_bavail
+- * is unsigned) */
+- p->available = fsp->fsu_bavail > fsp->fsu_bfree ? 0 : fsp->fsu_bavail;
++ p->available = fsp->fsu_bavail;
+ p->available_to_root = fsp->fsu_bfree;
+ p->used = fsp->fsu_blocks - fsp->fsu_bfree;
+ if (freespace_ignore_reserved) {
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1-r1.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..9c951f0457cf
--- /dev/null
+++ b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit flag-o-matic
+
+DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
+HOMEPAGE="https://www.monitoring-plugins.org/"
+SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+IUSE="curl gnutls ipv6 ldap mysql dns fping game postgres radius samba snmp ssh +ssl"
+
+# Most of the plugins use automagic dependencies, i.e. the plugin will
+# get built if the binary it uses is installed. For example, check_snmp
+# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
+# installed. End result: most of our runtime dependencies are required
+# at build time as well.
+#
+# REAL_DEPEND contains the dependencies that are actually needed to
+# build. DEPEND contains those plus the automagic dependencies.
+#
+REAL_DEPEND="dev-lang/perl
+ curl? (
+ dev-libs/uriparser
+ net-misc/curl
+ )
+ ldap? ( net-nds/openldap )
+ mysql? ( || ( dev-db/mysql-connector-c dev-db/mariadb-connector-c ) )
+ postgres? ( dev-db/postgresql:= )
+ ssl? (
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ gnutls? ( net-libs/gnutls )
+ )
+ radius? ( net-dialup/freeradius-client )"
+
+DEPEND="${REAL_DEPEND}
+ dns? ( net-dns/bind-tools )
+ game? ( games-util/qstat )
+ fping? ( net-analyzer/fping )
+ samba? ( net-fs/samba )
+ ssh? ( net-misc/openssh )
+ snmp? ( dev-perl/Net-SNMP
+ net-analyzer/net-snmp[-minimal] )"
+
+# Basically everything collides with nagios-plugins.
+RDEPEND="${DEPEND}
+ acct-group/nagios
+ acct-user/nagios
+ !net-analyzer/nagios-plugins"
+
+# At least one test is interactive.
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-fix-check-disk-on-btrfs.patch" #830249
+)
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # Use an array to prevent econf from mangling the ping args.
+ local myconf=()
+
+ if use ssl; then
+ myconf+=( $(use_with !gnutls openssl /usr)
+ $(use_with gnutls gnutls /usr) )
+ else
+ myconf+=( --without-openssl )
+ myconf+=( --without-gnutls )
+ fi
+
+ # The autodetection for these two commands can hang if localhost is
+ # down or ICMP traffic is filtered. Bug #468296.
+ myconf+=( --with-ping-command="/bin/ping -4 -n -U -w %d -c %d %s" )
+
+ if use ipv6; then
+ myconf+=( --with-ping6-command="/bin/ping -6 -n -U -w %d -c %d %s" )
+ fi
+
+ econf \
+ $(use_with curl libcurl) \
+ $(use_with curl uriparser) \
+ $(use_with mysql) \
+ $(use_with ipv6) \
+ $(use_with ldap) \
+ $(use_with postgres pgsql /usr) \
+ $(use_with radius) \
+ "${myconf[@]}" \
+ --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
+ --sysconfdir="/etc/nagios"
+}
+
+DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
+ NEWS README REQUIREMENTS SUPPORT THANKS )
+
+pkg_postinst() {
+ elog "This ebuild has a number of USE flags that determine what you"
+ elog "are able to monitor. Depending on what you want to monitor, some"
+ elog "or all of these USE flags need to be set."
+ elog
+ elog "The plugins are installed in ${EROOT}/usr/$(get_libdir)/nagios/plugins"
+}