summaryrefslogtreecommitdiff
path: root/net-analyzer/monitoring-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-14 07:56:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-14 07:56:51 +0000
commit2e4747a36a51fd58c21f3f00db959709e83fe08b (patch)
tree55b3fa7393c53b4b2fa2bb96fdae27d9d4444a97 /net-analyzer/monitoring-plugins
parent5c1e419582680cfb61e0ae777c693704f3a731e1 (diff)
gentoo auto-resync : 14:02:2023 - 07:56:50
Diffstat (limited to 'net-analyzer/monitoring-plugins')
-rw-r--r--net-analyzer/monitoring-plugins/Manifest2
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild16
2 files changed, 16 insertions, 2 deletions
diff --git a/net-analyzer/monitoring-plugins/Manifest b/net-analyzer/monitoring-plugins/Manifest
index 18ec6a2c076c..35c7a907ea21 100644
--- a/net-analyzer/monitoring-plugins/Manifest
+++ b/net-analyzer/monitoring-plugins/Manifest
@@ -6,5 +6,5 @@ DIST monitoring-plugins-2.3.2.tar.gz 2766966 BLAKE2B 1a9c35e8df22d5666005b4b79f5
DIST monitoring-plugins-2.3.3.tar.gz 2620192 BLAKE2B 47bd7e71cf470781bb3bd8c8437ebfccdc977e48a3eba1d83ba85c2c1a8c154c7db832e3bb7189bf669083a10069c7fe09c7235a00b35fd9a6d80afcdbb44246 SHA512 502274b47da2ad04d0e2e4e29baa7e5ad8b9a9ece36794dcdf7dfcc087de30e514ff6937eaaa26b93daad329fcd11b72c3c87cad826e6bf6bafffa450077706f
EBUILD monitoring-plugins-2.3.1-r4.ebuild 3128 BLAKE2B e98bc4bfd457e4d634560bf72b2edee08b47ed1b909bc691ade912ec5671da16f098d30ac62b1acb7512629f4da154836a9d01a7fca742f87b71f6cb8e0676e0 SHA512 f94963c668a11d67be9ab488ad39382d614bc0e246704fea51ca18bc3ec1dcf77c87fe36a3d3ab07b2d841fa7cbdb94db90d3bbca030458130b2087304e6c20f
EBUILD monitoring-plugins-2.3.2-r1.ebuild 3056 BLAKE2B 59998577d7cf252f72058e359c7dcae42a199e16a16005e01279891e7e3fcb5277e64af4a32e512b8675fca128706e89a3e7f24483f16b8b0815427e17e68909 SHA512 357f02b81f09d3bb6a7054b11e0e06184da6c02ddc5794c27bb64aa29b4792428bdcdfb4aa331d46e53230102bed5a4a91dca417d23efa232da85e59215e9301
-EBUILD monitoring-plugins-2.3.3-r1.ebuild 3173 BLAKE2B 92c3a723b58df6dc5cafac9fbf32867f7faac0b6071bf53eae8c12e94faaaceffa24c5aa47141b9955f0fc6a36d47ae65e3dcecf934738092ee7a1c18207487c SHA512 bb169029045f1706e1215a52dd1013dd8be03c99d3c65d2b3b30d8a2e47cabeaba6dde837939d2027c5fd17c06f4f23842dbdaeac35d7f1afac7dbbcdea6520b
+EBUILD monitoring-plugins-2.3.3-r1.ebuild 3597 BLAKE2B e7b506d3bd9c0c9f6771af2f12527cea1763178fbc59303e716848ca4db841b6bf16bf5b7ec3e4bf83cb1f3018735a6b54e10b9b800c955baf26b32669fb4873 SHA512 e2faba9fbc350c71a899464317c35a86d22795d3b2c52c87a83152ab511c3a80b4bed6787efc47f652acdc3428dad68b8dff825ab825e43d11f12887d56e1db7
MISC metadata.xml 1541 BLAKE2B 979f2ab54aa6fd684023c25a2725f45ce1c3edfcc98f7b79e0bee72937f0c385c71c8f8a2caaa60231bdf26c4649ded397eeafb046a46fdcda5247ca030724be SHA512 a8d68c666fa3e9e181ab3d7f469395b19e26b47145fdf96f1135c3eb5001404f66a8c046a236d25238e4e31adb6269c1da7020b5b92262d3a7cb4f6f8a0f49d9
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild
index 555d75dae179..c5b2c08d156d 100644
--- a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild
+++ b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI="8"
-inherit flag-o-matic
+inherit autotools flag-o-matic
DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
HOMEPAGE="https://www.monitoring-plugins.org/"
@@ -53,6 +53,7 @@ RDEPEND="${DEPEND}
acct-group/nagios
acct-user/nagios
!net-analyzer/nagios-plugins"
+BDEPEND="sys-devel/gettext"
# At least one test is interactive.
RESTRICT="test"
@@ -62,6 +63,19 @@ PATCHES=(
"${FILESDIR}/${PN}-fix-check-http-segfault.patch" #893252
)
+src_prepare() {
+ default
+
+ # Refresh the gettext macro to fix musl build, bug #892645
+ # This should be unnecessary in the next release (>2.3.3) as upstream
+ # refreshed its copy of gnulib, so on next release:
+ # - We may be able to drop the gettext BDEPEND (check!)
+ # - Drop this cp call
+ # - Drop eautoreconf
+ cp "${BROOT}"/usr/share/aclocal/gettext.m4 gl/m4/ || die
+ eautoreconf
+}
+
src_configure() {
append-flags -fno-strict-aliasing