summaryrefslogtreecommitdiff
path: root/net-analyzer/monitoring-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /net-analyzer/monitoring-plugins
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'net-analyzer/monitoring-plugins')
-rw-r--r--net-analyzer/monitoring-plugins/Manifest2
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/net-analyzer/monitoring-plugins/Manifest b/net-analyzer/monitoring-plugins/Manifest
index f560a4e5c6f4..6f4a67f30a76 100644
--- a/net-analyzer/monitoring-plugins/Manifest
+++ b/net-analyzer/monitoring-plugins/Manifest
@@ -1,6 +1,8 @@
AUX define-own-mysql-port-constant.patch 3296 BLAKE2B 7a7c88c6f2c71bc1fc2f802ad202c2d2dbf3ede5af55dbe46cc15a064d37178b27670e30aa7bea07147456ce4d3e1ce9f495fa6df9deb4095367a7427e217719 SHA512 3ead6340800ac15fbe76e223599a5b3dbc6b6b13b72b684919aa43487838564ad7117b4e67fa7f36f0f58554fd8b8d6233efbcb82e6927a0c31f22c6a9ab5dbb
DIST monitoring-plugins-2.2.tar.gz 2461548 BLAKE2B 0f68b492e089c6dfd09db6aab78ab4490f2e8983677c70dda4c3800a06380c066865587536a44f135d0e314006ed81a757cbfbd918f53e009f9d2c50b8e58db0 SHA512 5f8cfa132891d6d96e69bee3f2c26f7d4546f572be6a18f25ea5d9069f162cb2e424361289a5c26bec60d7b63d28a269437fd6f25645903a1c142fdcbbf77f27
+DIST monitoring-plugins-2.3.1.tar.gz 2529669 BLAKE2B 8dbbab78c1e57e249024fe57439acb41960585f2cccba20d03ca75a04b87e84752665f49cfe545c6a409d29094077dac0485aef872586f853e2f0f2187bf5070 SHA512 0ae76bc776997ed23d142ad9a688edc4df9b8ec0f9539b446e4fb4849a165cc88e97cbfb3a7a9a450de452e021d38f2e4ada7e8a22d78cf58e17e266472d01d7
DIST monitoring-plugins-2.3.tar.gz 2528556 BLAKE2B d8c8886aea900a172e5693de766edb6b7ef7aac5ee94fec1f5c14cb0e9873623b14a965cc8852abb4ed44934d5111a86e130e7c37201a03de42bc996797302de SHA512 926065667dff6c608ae5b7da39f6416bfc2443b9e1cdef68cd5d19be99da1b6fc6f23ef87b05731312b5d7ad76d01f0242fc9e544dbb4dd00dbafa0e27434d2e
EBUILD monitoring-plugins-2.2-r4.ebuild 2949 BLAKE2B ddde634c6dc7c986e4d08c80dd4d6d1024c1bcf8957810a1323e7ca4d6951d096efdd331e88b7ab39e3efc5421eb17769330b2a4868245559eea207db5fe9408 SHA512 a3e2b240dcc91492325cb6c24672cbaf481a43f0bffc241c13faf682e87aa1c27f1a1369614592784d6cb0e2ce2708a85109ae98a52d5703e245fd3dcef1c9d1
+EBUILD monitoring-plugins-2.3.1.ebuild 3037 BLAKE2B 07312abcb23007ba40f6be8d03e6884f2b0a5b69bd6c33d4e960aa7c482ad325499a00ff9f99a8c0dcb3a49d4e9ce174d65efbe0ca473e867ba66f540de0643b SHA512 fd969ca834c14f3443e43e7b49f917accd1cbfac84a5a87495faff56d404c406de0eb8521138579a50c533ab161e0002bcff37bd0734ec9fe83e7c75976a0e66
EBUILD monitoring-plugins-2.3.ebuild 3037 BLAKE2B 07312abcb23007ba40f6be8d03e6884f2b0a5b69bd6c33d4e960aa7c482ad325499a00ff9f99a8c0dcb3a49d4e9ce174d65efbe0ca473e867ba66f540de0643b SHA512 fd969ca834c14f3443e43e7b49f917accd1cbfac84a5a87495faff56d404c406de0eb8521138579a50c533ab161e0002bcff37bd0734ec9fe83e7c75976a0e66
MISC metadata.xml 1434 BLAKE2B 0d6304a4cc6f3d5b9ea268d7c6613f4613ac68ee1ae9d40079796716eb845ea97a1d8d6418d5dbaccdb7686754913f06dee8255ea12d91d3d8dc94e12fb55970 SHA512 0a9e64da453edddc864fc8b1c0fb13c63976f99968060a9ef2dc1d5e36b84dda9a79ac7dbe795401ef0680b35e397b08920a9a5ea4f861575bc61a76e89cde42
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1.ebuild
new file mode 100644
index 000000000000..8beced678194
--- /dev/null
+++ b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
+HOMEPAGE="https://www.monitoring-plugins.org/"
+SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+IUSE="curl gnutls ipv6 ldap mysql dns fping game postgres radius samba snmp ssh +ssl"
+
+# Most of the plugins use automagic dependencies, i.e. the plugin will
+# get built if the binary it uses is installed. For example, check_snmp
+# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
+# installed. End result: most of our runtime dependencies are required
+# at build time as well.
+#
+# REAL_DEPEND contains the dependencies that are actually needed to
+# build. DEPEND contains those plus the automagic dependencies.
+#
+REAL_DEPEND="dev-lang/perl
+ curl? (
+ dev-libs/uriparser
+ net-misc/curl
+ )
+ ldap? ( net-nds/openldap )
+ mysql? ( || ( dev-db/mysql-connector-c dev-db/mariadb-connector-c ) )
+ postgres? ( dev-db/postgresql:= )
+ ssl? (
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ gnutls? ( net-libs/gnutls )
+ )
+ radius? ( net-dialup/freeradius-client )"
+
+DEPEND="${REAL_DEPEND}
+ dns? ( net-dns/bind-tools )
+ game? ( games-util/qstat )
+ fping? ( net-analyzer/fping )
+ samba? ( net-fs/samba )
+ ssh? ( net-misc/openssh )
+ snmp? ( dev-perl/Net-SNMP
+ net-analyzer/net-snmp[-minimal] )"
+
+# Basically everything collides with nagios-plugins.
+RDEPEND="${DEPEND}
+ acct-group/nagios
+ acct-user/nagios
+ !net-analyzer/nagios-plugins"
+
+# At least one test is interactive.
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/define-own-mysql-port-constant.patch" )
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # Use an array to prevent econf from mangling the ping args.
+ local myconf=()
+
+ if use ssl; then
+ myconf+=( $(use_with !gnutls openssl /usr)
+ $(use_with gnutls gnutls /usr) )
+ else
+ myconf+=( --without-openssl )
+ myconf+=( --without-gnutls )
+ fi
+
+ # The autodetection for these two commands can hang if localhost is
+ # down or ICMP traffic is filtered. Bug #468296.
+ myconf+=( --with-ping-command="/bin/ping -4 -n -U -w %d -c %d %s" )
+
+ if use ipv6; then
+ myconf+=( --with-ping6-command="/bin/ping -6 -n -U -w %d -c %d %s" )
+ fi
+
+ econf \
+ $(use_with curl libcurl) \
+ $(use_with curl uriparser) \
+ $(use_with mysql) \
+ $(use_with ipv6) \
+ $(use_with ldap) \
+ $(use_with postgres pgsql /usr) \
+ $(use_with radius) \
+ "${myconf[@]}" \
+ --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
+ --sysconfdir="/etc/nagios"
+}
+
+DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
+ NEWS README REQUIREMENTS SUPPORT THANKS )
+
+pkg_postinst() {
+ elog "This ebuild has a number of USE flags that determine what you"
+ elog "are able to monitor. Depending on what you want to monitor, some"
+ elog "or all of these USE flags need to be set."
+ elog
+ elog "The plugins are installed in ${EROOT}/usr/$(get_libdir)/nagios/plugins"
+}