summaryrefslogtreecommitdiff
path: root/net-analyzer/linkchecker/linkchecker-9.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /net-analyzer/linkchecker/linkchecker-9.4.0-r1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'net-analyzer/linkchecker/linkchecker-9.4.0-r1.ebuild')
-rw-r--r--net-analyzer/linkchecker/linkchecker-9.4.0-r1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/net-analyzer/linkchecker/linkchecker-9.4.0-r1.ebuild b/net-analyzer/linkchecker/linkchecker-9.4.0-r1.ebuild
deleted file mode 100644
index 37d4981c5243..000000000000
--- a/net-analyzer/linkchecker/linkchecker-9.4.0-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite?"
-
-inherit bash-completion-r1 distutils-r1 optfeature
-
-DESCRIPTION="Check websites for broken links"
-HOMEPAGE="https://github.com/linkcheck/linkchecker"
-SRC_URI="https://github.com/linkcheck/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~ppc-macos ~x64-solaris"
-IUSE="sqlite"
-
-RDEPEND="
- dev-python/dnspython[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- >=dev-python/requests-2.2[${PYTHON_USEDEP}]
-"
-DEPEND=""
-
-RESTRICT="test"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}-9.3-bash-completion.patch"
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- delete_gui() {
- rm -rf \
- "${ED}"/usr/bin/linkchecker-gui* \
- "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
- }
-
- DOCS=(
- doc/changelog.txt
- doc/development.mdwn
- doc/python3.txt
- doc/upgrading.txt
- )
- distutils-r1_python_install_all
-
- python_foreach_impl delete_gui
- rm -f "${ED}"/usr/share/applications/linkchecker*.desktop || die
-
- newbashcomp config/linkchecker-completion ${PN}
-}
-
-pkg_postinst() {
- optfeature "bash-completion support" dev-python/argcomplete[${PYTHON_USEDEP}]
- optfeature "Virus scanning" app-antivirus/clamav
- optfeature "Geo IP support" dev-python/geoip-python[${PYTHON_USEDEP}]
-}