summaryrefslogtreecommitdiff
path: root/net-analyzer/linkchecker/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /net-analyzer/linkchecker/files
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'net-analyzer/linkchecker/files')
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-9.2-unbundle.patch30
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-9.3.1-build-fix.patch14
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-9.3.1-requests.patch46
3 files changed, 0 insertions, 90 deletions
diff --git a/net-analyzer/linkchecker/files/linkchecker-9.2-unbundle.patch b/net-analyzer/linkchecker/files/linkchecker-9.2-unbundle.patch
deleted file mode 100644
index 598f856b0007..000000000000
--- a/net-analyzer/linkchecker/files/linkchecker-9.2-unbundle.patch
+++ /dev/null
@@ -1,30 +0,0 @@
- setup.py | 7 -------
- 1 file changed, 7 deletions(-)
-
-diff --git a/setup.py b/setup.py
-old mode 100755
-new mode 100644
-index dc30a7d..d62622b
---- a/setup.py
-+++ b/setup.py
-@@ -900,9 +900,6 @@ o a command line, GUI and web interface
- 'py2exe': MyPy2exe,
- 'py2app': MyPy2app,
- },
-- package_dir = {
-- 'linkcheck_dns.dns': 'third_party/dnspython/dns',
-- },
- packages = [
- 'linkcheck',
- 'linkcheck.bookmarks',
-@@ -917,10 +914,6 @@ o a command line, GUI and web interface
- 'linkcheck.network',
- 'linkcheck.parser',
- 'linkcheck.plugins',
-- 'linkcheck_dns.dns',
-- 'linkcheck_dns.dns.rdtypes',
-- 'linkcheck_dns.dns.rdtypes.ANY',
-- 'linkcheck_dns.dns.rdtypes.IN',
- ],
- ext_modules = [
- Extension('linkcheck.HtmlParser.htmlsax',
diff --git a/net-analyzer/linkchecker/files/linkchecker-9.3.1-build-fix.patch b/net-analyzer/linkchecker/files/linkchecker-9.3.1-build-fix.patch
deleted file mode 100644
index bcfd2cc800e4..000000000000
--- a/net-analyzer/linkchecker/files/linkchecker-9.3.1-build-fix.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/setup.py b/setup.py
-index b42ed8c..ec206e6 100755
---- a/setup.py
-+++ b/setup.py
-@@ -654,8 +654,7 @@ myemail = "bastian.kleineidam@web.de"
-
- data_files = [
- ('share/linkchecker',
-- ['config/linkcheckerrc',
-- 'doc/html/lccollection.qhc', 'doc/html/lcdoc.qch']),
-+ ['config/linkcheckerrc']),
- ('share/linkchecker/examples',
- ['cgi-bin/lconline/leer.html.en',
- 'cgi-bin/lconline/leer.html.de',
diff --git a/net-analyzer/linkchecker/files/linkchecker-9.3.1-requests.patch b/net-analyzer/linkchecker/files/linkchecker-9.3.1-requests.patch
deleted file mode 100644
index 56c57fa37997..000000000000
--- a/net-analyzer/linkchecker/files/linkchecker-9.3.1-requests.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 9b12b5d66fa9b832f4d9e19a0b9dcb92607ee3e5 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Antoine=20Beaupr=C3=A9?= <anarcat@debian.org>
-Date: Mon, 2 Oct 2017 20:18:54 -0400
-Subject: [PATCH] workaround new limitation in requests
-
-newer requests do not expose the internal SSL socket object so we
-cannot verify certificates. there was work to allow custom
-verification routines which we could use, but this never finished:
-
-https://github.com/shazow/urllib3/pull/257
-
-so right now, just treat missing socket information as if the cert was
-missing.
-
-Closes: #76
----
- linkcheck/checker/httpurl.py | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/linkcheck/checker/httpurl.py b/linkcheck/checker/httpurl.py
-index 161619c5..bde77c70 100644
---- a/linkcheck/checker/httpurl.py
-+++ b/linkcheck/checker/httpurl.py
-@@ -194,6 +194,10 @@ def _get_ssl_sock(self):
- """Get raw SSL socket."""
- assert self.scheme == u"https", self
- raw_connection = self.url_connection.raw._connection
-+ if not raw_connection:
-+ # this happens with newer requests versions:
-+ # https://github.com/linkcheck/linkchecker/issues/76
-+ return None
- if raw_connection.sock is None:
- # sometimes the socket is not yet connected
- # see https://github.com/kennethreitz/requests/issues/1966
-@@ -204,7 +208,10 @@ def _add_ssl_info(self):
- """Add SSL cipher info."""
- if self.scheme == u'https':
- sock = self._get_ssl_sock()
-- if hasattr(sock, 'cipher'):
-+ if not sock:
-+ log.debug(LOG_CHECK, "cannot extract SSL certificate from connection")
-+ self.ssl_cert = None
-+ elif hasattr(sock, 'cipher'):
- self.ssl_cert = sock.getpeercert()
- else:
- # using pyopenssl