summaryrefslogtreecommitdiff
path: root/net-analyzer/knocker/knocker-0.7.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/knocker/knocker-0.7.1-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/knocker/knocker-0.7.1-r3.ebuild')
-rw-r--r--net-analyzer/knocker/knocker-0.7.1-r3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-analyzer/knocker/knocker-0.7.1-r3.ebuild b/net-analyzer/knocker/knocker-0.7.1-r3.ebuild
new file mode 100644
index 000000000000..9731d03bf7b7
--- /dev/null
+++ b/net-analyzer/knocker/knocker-0.7.1-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit base toolchain-funcs
+
+DESCRIPTION="Knocker is an easy to use security port scanner written in C"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://knocker.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README TO-DO )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fency.patch \
+ "${FILESDIR}"/${P}-free.patch \
+ "${FILESDIR}"/${P}-knocker_user_is_root.patch
+
+ tc-export CC
+}