summaryrefslogtreecommitdiff
path: root/net-analyzer/ifstat/ifstat-1.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/ifstat/ifstat-1.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/ifstat/ifstat-1.1-r2.ebuild')
-rw-r--r--net-analyzer/ifstat/ifstat-1.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/ifstat/ifstat-1.1-r2.ebuild b/net-analyzer/ifstat/ifstat-1.1-r2.ebuild
new file mode 100644
index 000000000000..98a8a89c5741
--- /dev/null
+++ b/net-analyzer/ifstat/ifstat-1.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit autotools eutils
+
+IUSE="snmp"
+
+DESCRIPTION="Network interface bandwidth usage, with support for snmp targets"
+SRC_URI="http://gael.roualland.free.fr/ifstat/${P}.tar.gz"
+HOMEPAGE="http://gael.roualland.free.fr/ifstat/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 hppa ~mips ppc ppc64 sparc x86"
+
+DEPEND="snmp? ( >=net-analyzer/net-snmp-5.0 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( HISTORY README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${P}-hardened.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with snmp)
+}