summaryrefslogtreecommitdiff
path: root/net-analyzer/icinga2/icinga2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-18 18:31:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-18 18:31:43 +0000
commitcd0d9000770337b445051f1852fe3971ceb7a6e2 (patch)
tree49c82dbb14c2d960e04e7482bdefe6ed2d53a173 /net-analyzer/icinga2/icinga2-9999.ebuild
parent12c505f7fcc9ddc89e96ed178df05aceec162d92 (diff)
gentoo auto-resync : 18:03:2023 - 18:31:42
Diffstat (limited to 'net-analyzer/icinga2/icinga2-9999.ebuild')
-rw-r--r--net-analyzer/icinga2/icinga2-9999.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/net-analyzer/icinga2/icinga2-9999.ebuild b/net-analyzer/icinga2/icinga2-9999.ebuild
index 2c5482fe5a8f..cf77ec3fb9e8 100644
--- a/net-analyzer/icinga2/icinga2-9999.ebuild
+++ b/net-analyzer/icinga2/icinga2-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake systemd
+inherit cmake
if [[ ${PV} != 9999 ]]; then
SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -18,7 +18,7 @@ HOMEPAGE="https://icinga.com/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="console jumbo-build lto mail mariadb minimal +mysql nano-syntax +plugins postgres systemd +vim-syntax"
+IUSE="console jumbo-build lto mail mariadb minimal +mysql +plugins postgres systemd"
# Add accounts to DEPEND because of fowners in src_install
DEPEND="
@@ -120,16 +120,12 @@ src_install() {
fperms ug+rwX,o-rwx /var/spool/icinga2
fperms ug+rwX,o-rwx /var/log/icinga2
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
- fi
+ insinto /usr/share/vim/vimfiles
+ doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
+ doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
- if use nano-syntax; then
- insinto /usr/share/nano
- doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
- fi
+ insinto /usr/share/nano
+ doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
}
pkg_postinst() {