summaryrefslogtreecommitdiff
path: root/net-analyzer/icinga2/icinga2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /net-analyzer/icinga2/icinga2-9999.ebuild
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'net-analyzer/icinga2/icinga2-9999.ebuild')
-rw-r--r--net-analyzer/icinga2/icinga2-9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/net-analyzer/icinga2/icinga2-9999.ebuild b/net-analyzer/icinga2/icinga2-9999.ebuild
index 635111837e4c..c0f291e4ea22 100644
--- a/net-analyzer/icinga2/icinga2-9999.ebuild
+++ b/net-analyzer/icinga2/icinga2-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="http://icinga.org/icinga2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins systemd +vim-syntax"
+IUSE="classicui console libressl lto mail mariadb minimal +mysql nano-syntax +plugins postgres systemd +vim-syntax"
WX_GTK_VER="3.0"
CDEPEND="
@@ -26,7 +26,8 @@ CDEPEND="
libressl? ( dev-libs/libressl:0= )
>=dev-libs/boost-1.58-r1
console? ( dev-libs/libedit )
- mysql? ( virtual/mysql )
+ mariadb? ( dev-db/mariadb-connector-c:= )
+ mysql? ( dev-db/mysql-connector-c:= )
postgres? ( dev-db/postgresql:= )
dev-libs/yajl"
@@ -44,7 +45,7 @@ RDEPEND="
mail? ( virtual/mailx )
classicui? ( net-analyzer/icinga[web] )"
-REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
+REQUIRED_USE="!minimal? ( || ( mariadb mysql postgres ) )"
want_apache2
@@ -115,7 +116,14 @@ src_install() {
newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
docinto schema/upgrade
dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
- elif use postgres ; then
+ fi
+ if use mariadb ; then # same as mysql
+ docinto schema
+ newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
+ docinto schema/upgrade
+ dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
+ fi
+ if use postgres ; then
docinto schema
newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
docinto schema/upgrade