summaryrefslogtreecommitdiff
path: root/net-analyzer/icinga2/icinga2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:07:46 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:07:46 +0100
commit3c0ac23fc220e56b44356d845aaf1b71df69c816 (patch)
tree6d455e0701684270c13f4c6e1f1919ecc2cd04ac /net-analyzer/icinga2/icinga2-9999.ebuild
parentf3b17e517082e3c6581428440a122f1a2679e278 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'net-analyzer/icinga2/icinga2-9999.ebuild')
-rw-r--r--net-analyzer/icinga2/icinga2-9999.ebuild21
1 files changed, 4 insertions, 17 deletions
diff --git a/net-analyzer/icinga2/icinga2-9999.ebuild b/net-analyzer/icinga2/icinga2-9999.ebuild
index ebdd790be879..3085070c612b 100644
--- a/net-analyzer/icinga2/icinga2-9999.ebuild
+++ b/net-analyzer/icinga2/icinga2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,7 @@ HOMEPAGE="http://icinga.org/icinga2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins studio +vim-syntax"
+IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins systemd +vim-syntax"
WX_GTK_VER="3.0"
CDEPEND="
@@ -41,8 +41,7 @@ RDEPEND="
net-analyzer/nagios-plugins
) )
mail? ( virtual/mailx )
- classicui? ( net-analyzer/icinga[web] )
- studio? ( x11-libs/wxGTK:3.0 )"
+ classicui? ( net-analyzer/icinga[web] )"
REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
@@ -50,9 +49,6 @@ want_apache2
pkg_setup() {
depend.apache_pkg_setup
- if use studio ; then
- setup-wxwidgets
- fi
enewgroup icinga
enewgroup icingacmd
enewgroup nagios # for plugins
@@ -74,6 +70,7 @@ src_configure() {
-DICINGA2_GROUP=icingacmd
-DICINGA2_COMMAND_GROUP=icingacmd
-DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
+ -DUSE_SYSTEMD=$(usex systemd ON OFF)
-DLOGROTATE_HAS_SU=ON
)
# default to off if minimal, allow the flags to be set otherwise
@@ -98,16 +95,6 @@ src_configure() {
-DICINGA2_LTO_BUILD=OFF
)
fi
- # STUDIO
- if use studio; then
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=OFF
- )
- fi
cmake-utils_src_configure
}