summaryrefslogtreecommitdiff
path: root/net-analyzer/hexinject
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/hexinject
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/hexinject')
-rw-r--r--net-analyzer/hexinject/Manifest4
-rw-r--r--net-analyzer/hexinject/files/hexinject-1.5-fix-build-system.patch15
-rw-r--r--net-analyzer/hexinject/hexinject-1.5.ebuild36
-rw-r--r--net-analyzer/hexinject/metadata.xml22
4 files changed, 77 insertions, 0 deletions
diff --git a/net-analyzer/hexinject/Manifest b/net-analyzer/hexinject/Manifest
new file mode 100644
index 000000000000..85baff35eabe
--- /dev/null
+++ b/net-analyzer/hexinject/Manifest
@@ -0,0 +1,4 @@
+AUX hexinject-1.5-fix-build-system.patch 433 SHA256 87a83bb89c834aba9f6fdf5e9c56de6473660278834ee67bfeeeabc64423f89c SHA512 db17bbb6d1ac936b5eedadd9460bacb1f59c21556fcc8c60e135920383d6990b0498a1f74182352b8061629934e728a865e2cba922abec4c7c7035bbc346e2e1 WHIRLPOOL cf691c1ff0c7c7d44abd85a2f6153fe99dce19319dcc009c9259c1a095deac79444ec47bb97b48fcf94b63fd2a6923997332f5b65327d5e8136af147d75b37dd
+DIST hexinject-1.5.tar.gz 14449 SHA256 329f0686069988ac0dae4a00082b205ac9669bc8e202d4b112c600bcbc198ce9 SHA512 cd145b6f2ae9d739effca03959fb474df11d28ff015c0e5bd1e30c341f60085154795f3c8a601b7241623944b3868b6fc9a3e1530a3aa4e7aaa2b3794a5aa34a WHIRLPOOL 96e065ca7135f12db6e5949fb8fd537e0981f5b0cc1d57d40eb59003aabc87ae2459872cb11108727c0032b6c5282d385512678859da081d783bc692f8044c93
+EBUILD hexinject-1.5.ebuild 756 SHA256 09565bedd7830e8f0d97ffdd8a51d4fe2da4ea8909b8e99465849c801184c513 SHA512 2d17be0ac7931ac94d94924681f8f6f7ed0ed4b2072f2e5e46a5bf1277b4a67b62cdcabdad61d3db5fc7eb216258135d4ce389e4cae4a5ab476a209a62878a92 WHIRLPOOL 8fd175a1aeaca97833912647e1e8414ee268c19a7bb229a7ed8fa227346e076036e319451037b8a39b75e342e21e9f4969680dc9f2c161f8b4d6f45e2d81152e
+MISC metadata.xml 893 SHA256 32347e309dbb0477991d4eafb310fdb1118fb88a40215d883b2978841c0e4d2f SHA512 6ef4476679512d3e08baf37a3c27c304613b281d1da242a675c3da4c907100fb98c594a8b03970e3b8a9571e441f4e6b40b4cd971199bcc62db6713161128367 WHIRLPOOL cb086d0d2c6d925621e4dd6a1d8d4008796b9672c6ff103bb893f6910fcf6e10928450fa30ec80af2d00c28f5858163feb2c230680c66d0860be47e190d1b340
diff --git a/net-analyzer/hexinject/files/hexinject-1.5-fix-build-system.patch b/net-analyzer/hexinject/files/hexinject-1.5-fix-build-system.patch
new file mode 100644
index 000000000000..046d083710df
--- /dev/null
+++ b/net-analyzer/hexinject/files/hexinject-1.5-fix-build-system.patch
@@ -0,0 +1,15 @@
+Respect user flags
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ all:
+- gcc -o hexinject hexinject.c -lpcap
+- gcc -o prettypacket prettypacket.c
+- gcc -o hex2raw hex2raw.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o hexinject hexinject.c -lpcap
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o prettypacket prettypacket.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o hex2raw hex2raw.c
+
+ clean:
+ rm -f hexinject prettypacket hex2raw *~
diff --git a/net-analyzer/hexinject/hexinject-1.5.ebuild b/net-analyzer/hexinject/hexinject-1.5.ebuild
new file mode 100644
index 000000000000..b33f5f0bda0c
--- /dev/null
+++ b/net-analyzer/hexinject/hexinject-1.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Network packet sniffer and injector"
+HOMEPAGE="http://hexinject.sourceforge.net/"
+SRC_URI="http://downloads.sourceforge.net/project/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tools experimental"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ experimental? ( dev-lang/tcl )"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5-fix-build-system.patch )
+
+src_prepare() {
+ default
+ append-cflags -std=gnu89
+ tc-export CC
+}
+
+src_install() {
+ dobin hexinject
+ use tools && dobin hex2raw prettypacket
+ use experimental && dobin packets.tcl
+ einstalldocs
+}
diff --git a/net-analyzer/hexinject/metadata.xml b/net-analyzer/hexinject/metadata.xml
new file mode 100644
index 000000000000..b4d8ef8ab509
--- /dev/null
+++ b/net-analyzer/hexinject/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ HexInject is a very versatile packet injector and sniffer, that provide
+ a command-line framework for raw network access. It's designed to work
+ together with others command-line utilities, and for this reason it
+ facilitates the creation of powerful shell scripts capable of reading,
+ intercepting and modifying network traffic in a transparent manner.
+ </longdescription>
+ <use>
+ <flag name="tools">Install hex2raw and prettypacket tools</flag>
+ <flag name="experimental">Install experimental packets.tcl</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">downloads</remote-id>
+ </upstream>
+</pkgmetadata>