summaryrefslogtreecommitdiff
path: root/net-analyzer/hexinject/hexinject-1.6-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-07 03:12:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-07 03:12:12 +0000
commit4e0f61672a4cd8a3d8afc21e9afc2a7acd849976 (patch)
tree20cba6f816bb34fdd956935e64d4432ed2427c65 /net-analyzer/hexinject/hexinject-1.6-r2.ebuild
parentd479c9c5c724c7b1300a98e44975f31f4f2e51dd (diff)
gentoo auto-resync : 07:12:2022 - 03:12:11
Diffstat (limited to 'net-analyzer/hexinject/hexinject-1.6-r2.ebuild')
-rw-r--r--net-analyzer/hexinject/hexinject-1.6-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/hexinject/hexinject-1.6-r2.ebuild b/net-analyzer/hexinject/hexinject-1.6-r2.ebuild
new file mode 100644
index 000000000000..bfef01f88b8f
--- /dev/null
+++ b/net-analyzer/hexinject/hexinject-1.6-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Network packet sniffer and injector"
+HOMEPAGE="http://hexinject.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tools experimental"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ experimental? ( dev-lang/tcl )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin hexinject
+ use tools && dobin hex2raw prettypacket
+ use experimental && dobin packets.tcl
+ einstalldocs
+}