summaryrefslogtreecommitdiff
path: root/net-analyzer/gvm-libs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /net-analyzer/gvm-libs/files
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'net-analyzer/gvm-libs/files')
-rw-r--r--net-analyzer/gvm-libs/files/gvm-libs-20.8.1-disable-automagic-dep.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-analyzer/gvm-libs/files/gvm-libs-20.8.1-disable-automagic-dep.patch b/net-analyzer/gvm-libs/files/gvm-libs-20.8.1-disable-automagic-dep.patch
new file mode 100644
index 000000000000..3cd4a42272a5
--- /dev/null
+++ b/net-analyzer/gvm-libs/files/gvm-libs-20.8.1-disable-automagic-dep.patch
@@ -0,0 +1,22 @@
+diff --git a/util/CMakeLists.txt b/util/CMakeLists.txt
+index 3f10a4b8..223752e0 100644
+--- a/util/CMakeLists.txt
++++ b/util/CMakeLists.txt
+@@ -102,7 +102,7 @@ if (BUILD_WITH_RADIUS)
+ find_library (LIBRADCLI radcli)
+ endif (NOT LIBFREERADIUS)
+ if (NOT LIBFREERADIUS AND NOT LIBRADCLI)
+- message (STATUS " No suitable radius library found - radius support disabled")
++ message (SEND_ERROR " No suitable radius library found")
+ elseif (LIBFREERADIUS)
+ message (STATUS " Found ${LIBFREERADIUS} - radius support enabled")
+ set (RADIUS_LDFLAGS "-lfreeradius-client")
+@@ -122,7 +122,7 @@ if (BUILD_WITH_LDAP)
+ find_library (LIBLDAP ldap)
+ endif (NOT LIBLDAP)
+ if (NOT LIBLDAP)
+- message (STATUS " No ldap library found - ldap support disabled")
++ message (SEND_ERROR " No ldap library found")
+ else (NOT LIBLDAP)
+ message (STATUS " Found ${LIBLDAP} - ldap support enabled")
+ add_definitions (-DENABLE_LDAP_AUTH=1)