summaryrefslogtreecommitdiff
path: root/net-analyzer/gspoof/gspoof-3.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/gspoof/gspoof-3.2-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/gspoof/gspoof-3.2-r2.ebuild')
-rw-r--r--net-analyzer/gspoof/gspoof-3.2-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/gspoof/gspoof-3.2-r2.ebuild b/net-analyzer/gspoof/gspoof-3.2-r2.ebuild
new file mode 100644
index 000000000000..618d875e8c41
--- /dev/null
+++ b/net-analyzer/gspoof/gspoof-3.2-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="A simple GTK/command line TCP/IP packet generator"
+HOMEPAGE="http://gspoof.sourceforge.net/"
+SRC_URI="http://gspoof.sourceforge.net/src/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+IUSE=""
+
+DEPEND="
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ net-libs/libnet:1.1
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-def-values.patch \
+ "${FILESDIR}"/${P}-icon.patch
+ sed -i configure.ac -e 's|libnet.a|libnet.so|g' || die
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin gspoof
+ newicon pixmap/icon.png ${PN}.png
+ dodoc README CHANGELOG TODO
+}