summaryrefslogtreecommitdiff
path: root/net-analyzer/gsa
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /net-analyzer/gsa
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'net-analyzer/gsa')
-rw-r--r--net-analyzer/gsa/Manifest4
-rw-r--r--net-analyzer/gsa/gsa-21.4.4.ebuild42
-rw-r--r--net-analyzer/gsa/metadata.xml20
3 files changed, 66 insertions, 0 deletions
diff --git a/net-analyzer/gsa/Manifest b/net-analyzer/gsa/Manifest
new file mode 100644
index 000000000000..a90c1b5654d5
--- /dev/null
+++ b/net-analyzer/gsa/Manifest
@@ -0,0 +1,4 @@
+DIST gsa-21.4.2-node_modules.tar.gz 86572528 BLAKE2B 1aec3d8636241d7cd4ca591133cdadd26d349bf4342ee1595a678871617b4b3a763348a7a0e6d44b50780f330362131d7ba72953a40f53e79b1f9709775999fb SHA512 c44f3822864b9f68cbfe0e4052b2295ab74cb2c429cd9aa667b19b8cfb423c49dc65b1455f785abecdc4329f31b43fe368b0bd5276b4ad95d5fa2e208bb4a4ec
+DIST gsa-21.4.4.tar.gz 2471442 BLAKE2B b3ac937a87038d93e90223f7c33d087b0dbb043c4fcaa8a00c9d44148e686c064fdcc311899b7b3b4084658d23193bc128fb809f22621583898551f4348ece6f SHA512 5a7b45132a049adf608ccd8988d69a415290cc57d6e7537835a78e19aafb5dfdf204197576f69277726587efaccce189c1ccab55c43e5a0a7855c538b3bc4b67
+EBUILD gsa-21.4.4.ebuild 1036 BLAKE2B 9b929e395348dd2ab4eb93a377d23feb32689be41a95df04bde261860081f981349f122256e9f1133e277ed5b9c2e995100ee2e8c5cb4e692f4333877bb3b6d7 SHA512 9fe0def0a89ad904eeb9fe729e4a260ce186e6de1ef1f8cba36700b14bad32c2d37bb8f0f6d857146700dd84dce15747033cec93649b7bbdb3582e7da5be796e
+MISC metadata.xml 844 BLAKE2B c354d74c6109f19e9abb07a434af70de3d1dc78603a47b36fcfad8a52125a372a02be4069458ebafdfd602200f8cf39a46e1acbffa44b7c270b35f61c4102fe6 SHA512 10a27dd22f1db595c1bd933694ff96bdd28cf3229f4676ea88ea7055da0087c9e1ddc0e0fc46ac5e3eebd1f31f58ec7f00a24bcac9569ef76663eb44fe0e3751
diff --git a/net-analyzer/gsa/gsa-21.4.4.ebuild b/net-analyzer/gsa/gsa-21.4.4.ebuild
new file mode 100644
index 000000000000..c806a73a5931
--- /dev/null
+++ b/net-analyzer/gsa/gsa-21.4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_NODE_N="node_modules"
+MY_NODE_PV="21.4.2"
+
+DESCRIPTION="Greenbone Security Assistant"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/gsa"
+SRC_URI="
+ https://github.com/greenbone/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/greenbone/${PN}/releases/download/v${MY_NODE_PV}/gsa-node-modules-${MY_NODE_PV}.tar.gz -> ${PN}-${MY_NODE_PV}-${MY_NODE_N}.tar.gz
+"
+
+SLOT="0"
+LICENSE="AGPL-3+"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=net-libs/nodejs-14.0.0[ssl]
+ >=sys-apps/yarn-1.15.2
+"
+
+MY_NODE_DIR="${S}/${MY_NODE_N}/"
+
+src_prepare() {
+ default
+ # We will use pre-generated npm stuff.
+ mv "${WORKDIR}/${MY_NODE_N}" "${MY_NODE_DIR}" || die "couldn't move node_modules"
+}
+
+src_compile() {
+ # setting correct PATH for finding react-js
+ NODE_ENV=production PATH="${PATH}:${MY_NODE_DIR}/.bin/" \
+ yarn --offline build || die
+}
+
+src_install() {
+ insinto "usr/share/gvm/gsad/web"
+ doins -r build/*
+}
diff --git a/net-analyzer/gsa/metadata.xml b/net-analyzer/gsa/metadata.xml
new file mode 100644
index 000000000000..e0d8b744cdb9
--- /dev/null
+++ b/net-analyzer/gsa/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jonas.licht@gmail.com</email>
+ <name>Jonas Licht</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Greenbone Security Assistant is the web interface developed for the Greenbone Security Manager appliances.
+ It connects to the Greenbone Vulnerability Manager GVM to provide a full-featured user interface for vulnerability management.
+ Greenbone Security Assistant consists of GSA - The webpage written in React and
+ </longdescription>
+ <upstream>
+ <remote-id type="github">greenbone/gsa</remote-id>
+ </upstream>
+</pkgmetadata>