summaryrefslogtreecommitdiff
path: root/net-analyzer/graphite-web
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /net-analyzer/graphite-web
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'net-analyzer/graphite-web')
-rw-r--r--net-analyzer/graphite-web/Manifest2
-rw-r--r--net-analyzer/graphite-web/graphite-web-1.1.10.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/net-analyzer/graphite-web/Manifest b/net-analyzer/graphite-web/Manifest
index ad7cba0188c3..43cf39d4d1cd 100644
--- a/net-analyzer/graphite-web/Manifest
+++ b/net-analyzer/graphite-web/Manifest
@@ -1,5 +1,7 @@
AUX graphite-web-1.1.7-fhs-paths.patch 2691 BLAKE2B fbb09dfef58d94ef7099e98134d46122c2a82ab3cb0af4bd0cb92102f0e924c3efe80f481f898c81358722f7ad312a1168310ebbbc731c18ab788e1a81cf04ce SHA512 1a8bd3f62163004993f676a039035880512bb1add5f0cc80193471f2cfa483277bd24dd36b3b2b5c6e8faa6d83a029e59c5ea8cb8b713c6d063fe212b921c6a8
AUX graphite-web-1.1.8-pyparsing3.patch 2529 BLAKE2B 644b729b439a7fca9b8e2df1bede1cda48323694686a6c05378cb7a6112353add56ede35136e1c4f73611c5606be8345ee926f6e99b8dfac15c5ab72e133ac48 SHA512 8f837db47d66d859c247b96077ad4e44168123409fb43a074ab6f625c9235c010557da56dfa788851c8a0d18b4ad314dae085cf63bcaf8ec97e8e6f33f9f7b4c
+DIST graphite-web-1.1.10.tar.gz 1192965 BLAKE2B cd60e38a70c124c2be53c12394e994f4772a3fcdbae5fa8f26097e79de3de326ec90d5ee23b4e2e8c696e50d7d7ba897b6bb441a1fc7692d1b6e581c11a3da04 SHA512 fb0a2ed5cfa4a8c12bbb7f64f0c7846b439d8094a0b415e5750fe175bbcc2c047fccad50fdeda7696aee0ed9532eb75948f3a376ee34e188cacf226c02bbb3f9
DIST graphite-web-1.1.8.tar.gz 1177214 BLAKE2B 20e058feff0fa7f12393cfd41acca7cf05ff6a3995aa5f6547764fae3b8824e8b424efb8d5d47227eb2b5591ae6b45ab960da30f810acb4f1fbd0b9ae78ec47b SHA512 4637a541e61f56c1ac69bf18e7eab88ecf93f59099dc3e8022d8bf8fb1b204672bc0a1b5302e5031701714db17aabb316ba40f4cfabb2bf4fb0dedb8f412e4a9
+EBUILD graphite-web-1.1.10.ebuild 3178 BLAKE2B 9428840b3f83a4a14f2d8a069248b9670901e2daa028a7362b35409f4c6737997a00bb5d5208b2240d8217be2c4745e966ad257663b992b5508ceaebe3dbb5f2 SHA512 f9b9d7de7066370db98e9222924fe0ca1b8fac9530f60ab484de37744909c22eec9ef558afa2103bb370a1d34b7060a8c46a53e71f545dbe1d9ce5b11e4c5dc4
EBUILD graphite-web-1.1.8-r3.ebuild 3273 BLAKE2B c8d999b3ad12098e5b85961a3750ab013477d4c4b77e09868ae0640ccdca9bf5bcc0febd025e8dcbee75e7c0c4bbc4fbd5e695885df7b6018edf36e2644d824c SHA512 57402ecd2065bbe1a4878c63ee08008a442acfab6d508fd3331b8957a5d097da103a04ee21eec06b8cba678751e07aa84907031d84d68fa85a5a8df852005e8d
MISC metadata.xml 593 BLAKE2B 35159475d570570bde9acc2dd8d6abdf742d03ced88259125cc474f9ea2b9bfcf80c64da1dd44bcb69e55390d72c11c8aaa3b947f68571940c3b8676e6024387 SHA512 7a07c214a85f09ded5ecb5a353d96fc746c5c67f5c71f7539647651fd1519e78e1a3887a4865e9dab59d9804a9b0d801cc1ee72e0fd7225fe75273790e31e28f
diff --git a/net-analyzer/graphite-web/graphite-web-1.1.10.ebuild b/net-analyzer/graphite-web/graphite-web-1.1.10.ebuild
new file mode 100644
index 000000000000..ca42298c3bf5
--- /dev/null
+++ b/net-analyzer/graphite-web/graphite-web-1.1.10.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=no # export USE_SETUPTOOLS to activate
+
+inherit distutils-r1 prefix
+
+DESCRIPTION="Enterprise scalable realtime graphing"
+HOMEPAGE="https://graphiteapp.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+carbon ldap mysql memcached postgres +sqlite"
+
+DEPEND=""
+RDEPEND="
+ carbon? ( dev-python/carbon[${PYTHON_USEDEP}] )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
+ memcached? ( dev-python/python-memcached[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysqlclient[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ >=dev-python/django-1.11.19[sqlite?,${PYTHON_USEDEP}]
+ <dev-python/django-4[sqlite?,${PYTHON_USEDEP}]
+ >=dev-python/django-tagging-0.4.6[${PYTHON_USEDEP}]
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ media-libs/fontconfig
+"
+
+PATCHES=(
+ # Do not install the configuration and data files. We install them
+ # somewhere sensible by hand.
+ "${FILESDIR}"/${PN}-1.1.7-fhs-paths.patch
+)
+
+python_prepare_all() {
+ # Use a less common name
+ mv bin/build-index bin/${PN}-build-index || die
+ # use FHS-style paths
+ export GRAPHITE_NO_PREFIX=yes
+ distutils-r1_python_prepare_all
+ eprefixify \
+ conf/graphite.wsgi.example \
+ webapp/graphite/local_settings.py.example
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ keepdir /var/{lib,log}/${PN}
+ docinto examples
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc \
+ examples/example-graphite-vhost.conf \
+ conf/dashboard.conf.example \
+ conf/graphite.wsgi.example
+}
+
+python_install() {
+ distutils-r1_python_install \
+ --install-data="${EPREFIX}"/usr/share/${PN}
+
+ # copy the file once, to keep the timestamps correct, #808863
+ if [[ ! -e ${ED}/etc/${PN}/local_settings.py ]] ; then
+ insinto /etc/${PN}
+ newins webapp/graphite/local_settings.py.example local_settings.py
+ fi
+ pushd "${D}/$(python_get_sitedir)"/graphite > /dev/null || die
+ ln -s ../../../../../etc/${PN}/local_settings.py local_settings.py || die
+ popd > /dev/null || die
+
+ python_optimize
+}
+
+pkg_config() {
+ "${EROOT}"/usr/bin/django-admin.py migrate \
+ --settings=graphite.settings --run-syncdb
+ "${EROOT}"/usr/bin/${PN}-build-index
+}
+
+pkg_postinst() {
+ # Only display this for new installs
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You need to configure ${PN} to run with a WSGI server of your choice."
+ elog "For example using Apache, you can use www-apache/mod_wsgi,"
+ elog " using Nginx, you can use www-servers/uwsgi."
+ elog "Don't forget to edit local_settings.py in ${EPREFIX}/etc/${PN}"
+ elog "See https://graphite.readthedocs.org/en/latest/config-local-settings.html"
+ elog "Run emerge --config =${PN}-${PVR} if this is a fresh install."
+ elog ""
+ elog "If you want to update the search index regularily, you should consider running"
+ elog "the '${PN}-build-index' script in a crontab."
+ fi
+}