summaryrefslogtreecommitdiff
path: root/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild')
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
new file mode 100644
index 000000000000..e31c44e5a78a
--- /dev/null
+++ b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio fosphor block (GPU spectrum display)"
+HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+glfw qt4"
+
+RDEPEND="qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ >=net-wireless/gnuradio-3.7_rc:0=[qt4?,${PYTHON_USEDEP}]
+ media-libs/freetype
+ dev-libs/boost:=
+ glfw? ( >=media-libs/glfw-3 )
+ virtual/opencl
+ virtual/opengl
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig:0
+ dev-util/cppunit
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ # tries to run OpenCL test program, but failing doesn't hurt
+ addpredict /dev/dri
+
+ local mycmakeargs="
+ $(cmake-utils_use_enable glfw GLFW)
+ $(cmake-utils_use_enable qt4 QT)
+ -DENABLE_PYTHON=ON
+ -DENABLE_WX=OFF
+ "
+ cmake-utils_src_configure
+}