summaryrefslogtreecommitdiff
path: root/net-analyzer/gr-fosphor/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-23 20:45:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-23 20:45:29 +0100
commit26062b5638b6d2a6eedba7797ed6dde6f3d1f01c (patch)
tree39029c21f40249c93a1ca385bf838b14e41aecae /net-analyzer/gr-fosphor/files
parentcdfd4f0c915964d401cba19362c7dea8e89ad1da (diff)
gentoo auto-resync : 23:08:2022 - 20:45:29
Diffstat (limited to 'net-analyzer/gr-fosphor/files')
-rw-r--r--net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20210108-fix-use.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20210108-fix-use.patch b/net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20210108-fix-use.patch
new file mode 100644
index 000000000000..da3287f35496
--- /dev/null
+++ b/net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20210108-fix-use.patch
@@ -0,0 +1,18 @@
+diff --git a/python/bindings/CMakeLists.txt b/python/bindings/CMakeLists.txt
+index b7054da..86e5461 100644
+--- a/python/bindings/CMakeLists.txt
++++ b/python/bindings/CMakeLists.txt
+@@ -54,10 +54,11 @@ endmacro(GR_PYBIND_MAKE)
+
+ list(APPEND fosphor_python_files
+ base_sink_c_python.cc
+- glfw_sink_c_python.cc
+- qt_sink_c_python.cc
+ python_bindings.cc)
+
++list_cond_append(ENABLE_GLFW fosphor_python_files glfw_sink_c_python.cc)
++list_cond_append(ENABLE_QT fosphor_python_files qt_sink_c_python.cc)
++
+ GR_PYBIND_MAKE(fosphor
+ ../..
+ gr::fosphor