summaryrefslogtreecommitdiff
path: root/net-analyzer/goaccess/goaccess-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-27 15:10:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-27 15:10:20 +0100
commitc268590c556cb766e1ca3f55fde8a40cdde19c44 (patch)
tree7ebbcf748f02d29ba96741221f2e1919db85cdf9 /net-analyzer/goaccess/goaccess-9999.ebuild
parent2be230a2a252e8e744f11a8b38e9a0097ddc9b25 (diff)
gentoo auto-resync : 27:09:2022 - 15:10:20
Diffstat (limited to 'net-analyzer/goaccess/goaccess-9999.ebuild')
-rw-r--r--net-analyzer/goaccess/goaccess-9999.ebuild69
1 files changed, 45 insertions, 24 deletions
diff --git a/net-analyzer/goaccess/goaccess-9999.ebuild b/net-analyzer/goaccess/goaccess-9999.ebuild
index 4f3beee63c9e..084f44d4032a 100644
--- a/net-analyzer/goaccess/goaccess-9999.ebuild
+++ b/net-analyzer/goaccess/goaccess-9999.ebuild
@@ -1,51 +1,72 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools
+EGIT_REPO_URI="https://github.com/allinurl/${PN}.git"
-if [[ ${PV} = *9999* ]] ; then
- EGIT_REPO_URI="https://github.com/allinurl/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://tar.goaccess.io/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux"
-fi
+inherit autotools git-r3 optfeature systemd tmpfiles
-DESCRIPTION="A real-time web log analyzer and interactive viewer that runs in a terminal"
+DESCRIPTION="A real-time web log analyzer and interactive viewer in a terminal"
HOMEPAGE="https://goaccess.io"
+SRC_URI=""
LICENSE="MIT"
SLOT="0"
+KEYWORDS=""
IUSE="debug geoip geoipv2 getline ssl unicode"
REQUIRED_USE="geoipv2? ( geoip )"
-BDEPEND="virtual/pkgconfig"
-RDEPEND="sys-libs/ncurses:=[unicode(+)?]
+RDEPEND="acct-group/goaccess
+ acct-user/goaccess
+ sys-libs/ncurses:=[unicode(+)?]
geoip? (
!geoipv2? ( dev-libs/geoip )
geoipv2? ( dev-libs/libmaxminddb:0= )
)
- ssl? (
- dev-libs/openssl:0=
- )"
+ ssl? ( dev-libs/openssl:0= )"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
- # Change path to GeoIP bases in config
- sed -i -e s':/usr/local:/usr:' config/goaccess.conf || die "sed failed for goaccess.conf"
+ # Enable log-format, define log file and db path,
+ # change path to GeoIP bases in config
+ sed -i -e '/log-format COMBINED/s/#//' \
+ -e '/log-file/s/#//' \
+ -e '/db-path/s|tmp|var/lib/goaccess|' \
+ -e '/geoip-database/s|local/||' config/goaccess.conf \
+ || die "sed failed for goaccess.conf"
eautoreconf
}
src_configure() {
- econf \
- "$(use_enable debug)" \
- "$(use_enable geoip geoip "$(usex geoipv2 mmdb legacy)")" \
- "$(use_enable unicode utf8)" \
- "$(use_with getline)" \
- "$(use_with ssl openssl)"
+ local myeconfargs=()
+ readarray -t myeconfargs < <(
+ use_enable debug
+ use_enable geoip geoip "$(usex geoipv2 mmdb legacy)"
+ use_enable unicode utf8
+ use_with getline
+ use_with ssl openssl
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/goaccess.initd goaccess
+ newconfd "${FILESDIR}"/goaccess.confd goaccess
+ systemd_dounit "${FILESDIR}"/goaccess.service
+ newtmpfiles "${FILESDIR}"/goaccess.tmpfile goaccess.conf
+
+ diropts -o goaccess -g goaccess -m 0700
+ keepdir /var/lib/goaccess/db /var/log/goaccess
+}
+
+pkg_postinst() {
+ optfeature "update GeoIP databases" net-misc/geoipupdate
+ tmpfiles_process goaccess.conf
}