summaryrefslogtreecommitdiff
path: root/net-analyzer/fragroute
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /net-analyzer/fragroute
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'net-analyzer/fragroute')
-rw-r--r--net-analyzer/fragroute/Manifest1
-rw-r--r--net-analyzer/fragroute/fragroute-1.2.6-r4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/fragroute/Manifest b/net-analyzer/fragroute/Manifest
index c256bb6717c5..14448334565e 100644
--- a/net-analyzer/fragroute/Manifest
+++ b/net-analyzer/fragroute/Manifest
@@ -3,4 +3,5 @@ AUX fragroute-1.2.6-pcap_open.patch 1171 BLAKE2B cdd664bea732c2abab0813526eba79a
DIST fragroute-1.2.6-ipv6.tar.gz 163309 BLAKE2B c1927fdb6fbe6873b62fa48c5355b0b0d2be7b2183c94f259b8e0b4b3dec8a171defc4c6fbde507e522b28dffcc86dd68ae0ffe380a9d21eb478ebe7068d4beb SHA512 76c6fbe37100a43df477f0ba455a2bed6ac53c1f369e147d220562a34eca0eb273171e4b9ff4f3fc473c3f99a8344f6d49963c20d7cfaf6879200322a491ffc3
EBUILD fragroute-1.2.6-r1.ebuild 1037 BLAKE2B 81e3443bdd270b36cbf94e88412cd3220befc5faf843bf1619e3ba2f8fca3a5eadaf5cf40983e265bb214c12fb7af9bc2e59780f26bb5992f4dbdbf38514b687 SHA512 49b02420969d14fcba01898ac514f8fe2342a0cb9eae0e74eb3f685930d9bd7802200c3d9c4b9f62061ab1422018a8b93a45ef0819547fd092c5f134b26ce534
EBUILD fragroute-1.2.6-r3.ebuild 1084 BLAKE2B b8474ef0ce515758463ad4b7bfaea6f1834c201ea17273fc9f86bc5698cbe729a32d64cb6902d44b293d7c3c210f6772d49ab7fbaee27dddf19423189c08c8aa SHA512 ed76c00c900f281715fa38ed7d254e290b7cade2f152ab007faa76f99be4d53cdf86f1242cdcc14efb06ed13211c1e64cc8d6a5b591ac8c263615f8c76d72ceb
+EBUILD fragroute-1.2.6-r4.ebuild 1079 BLAKE2B ec7b1b983de3ad65d0e7dec0c2ed2d2860360af485c973677f77e81a89eb3203a0d90489d05ab7581ddd9039598395733ebf9fbd953ff5b413cb769f26c664d1 SHA512 20ba8dd271f209770ac2fe8c55b2f7232419173dbec127f53e9910842fb430a1b88b2e01a353de79bb020b3ea25707c28b82413ee8723350650abd4aca59f976
MISC metadata.xml 364 BLAKE2B 6f99923afef64e689bb2169801086f433f54879999551e8ac7e74f3c49ae10b2381041e626a024efe57b167a9394219b3ff3f313b049b2d40ba5404134b766c1 SHA512 3b38ee5be21d5a6957e39fea01461187f01f5b34a0538df8b6f6c217e0832a5d6cb5dbd9b6508cb5a977618dd9f8ffb0d0feefb0ec6c050efcfb4fa68a00ed78
diff --git a/net-analyzer/fragroute/fragroute-1.2.6-r4.ebuild b/net-analyzer/fragroute/fragroute-1.2.6-r4.ebuild
new file mode 100644
index 000000000000..58e9d754203b
--- /dev/null
+++ b/net-analyzer/fragroute/fragroute-1.2.6-r4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+MY_P="${P}-ipv6"
+inherit autotools
+
+DESCRIPTION="Testing of network intrusion detection systems, firewalls and TCP/IP stacks"
+HOMEPAGE="https://github.com/stsi/fragroute-ipv6"
+SRC_URI="https://fragroute-ipv6.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-libs/libdnet-1.14-r1
+ dev-libs/libevent:=
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/awk
+"
+DOCS=( INSTALL README TODO )
+PATCHES=(
+ "${FILESDIR}"/${P}-libdir.patch
+ "${FILESDIR}"/${P}-pcap_open.patch
+)
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Remove broken and old files, autotools will regen needed files
+ rm *.m4 acconfig.h missing Makefile.in || die
+
+ # Add missing includes
+ sed -i -e "/#define IPUTIL_H/a#include <stdio.h>\n#include <stdint.h>" iputil.h || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ DNETINC='' \
+ DNETLIB=-ldnet \
+ EVENTINC='' \
+ EVENTLIB=-levent \
+ PCAPINC='' \
+ PCAPLIB=-lpcap
+}