summaryrefslogtreecommitdiff
path: root/net-analyzer/fragroute
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /net-analyzer/fragroute
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'net-analyzer/fragroute')
-rw-r--r--net-analyzer/fragroute/Manifest3
-rw-r--r--net-analyzer/fragroute/files/fragroute-1.2.6-pcap_open.patch44
-rw-r--r--net-analyzer/fragroute/fragroute-1.2.6-r1.ebuild (renamed from net-analyzer/fragroute/fragroute-1.2.6.ebuild)30
3 files changed, 61 insertions, 16 deletions
diff --git a/net-analyzer/fragroute/Manifest b/net-analyzer/fragroute/Manifest
index d89f0f5ad620..835d47b3aab9 100644
--- a/net-analyzer/fragroute/Manifest
+++ b/net-analyzer/fragroute/Manifest
@@ -1,3 +1,4 @@
+AUX fragroute-1.2.6-pcap_open.patch 1171 BLAKE2B cdd664bea732c2abab0813526eba79a7dd7beef3c373a7f86414356d786f47b950561a74ed5bc9d404a7b39f63ab12c5b711835b056fccbda8583f8e7541c5ed SHA512 f60abf95fa5bd8798cf88f40d972311bbee4f877ee46cee1aa6e4438b5e4dd6c3b990b5e2565d24d1ce9c72d23f950ef13abd889d11a2f1bf6f34fb01957e7c6
DIST fragroute-1.2.6-ipv6.tar.gz 163309 BLAKE2B c1927fdb6fbe6873b62fa48c5355b0b0d2be7b2183c94f259b8e0b4b3dec8a171defc4c6fbde507e522b28dffcc86dd68ae0ffe380a9d21eb478ebe7068d4beb SHA512 76c6fbe37100a43df477f0ba455a2bed6ac53c1f369e147d220562a34eca0eb273171e4b9ff4f3fc473c3f99a8344f6d49963c20d7cfaf6879200322a491ffc3
-EBUILD fragroute-1.2.6.ebuild 1101 BLAKE2B f2d9cbc7e8a59fbf1bc2a5914888a6d7371d038e3501666ea6d0dc0c30cb9b7af67c6dcabb59643bbe8c8615abe518f95ed40185c30d893767e4732a0ee4d6ee SHA512 7b7f40e9bffe3e94fe8c8ae24d8bfde92af603de773500d90f9dfa3707140b2c5f27c57fe75945fd81d9596ac51c85dd66c9d1315a4d91729c22ffaa437f29e9
+EBUILD fragroute-1.2.6-r1.ebuild 1037 BLAKE2B 81e3443bdd270b36cbf94e88412cd3220befc5faf843bf1619e3ba2f8fca3a5eadaf5cf40983e265bb214c12fb7af9bc2e59780f26bb5992f4dbdbf38514b687 SHA512 49b02420969d14fcba01898ac514f8fe2342a0cb9eae0e74eb3f685930d9bd7802200c3d9c4b9f62061ab1422018a8b93a45ef0819547fd092c5f134b26ce534
MISC metadata.xml 364 BLAKE2B 6f99923afef64e689bb2169801086f433f54879999551e8ac7e74f3c49ae10b2381041e626a024efe57b167a9394219b3ff3f313b049b2d40ba5404134b766c1 SHA512 3b38ee5be21d5a6957e39fea01461187f01f5b34a0538df8b6f6c217e0832a5d6cb5dbd9b6508cb5a977618dd9f8ffb0d0feefb0ec6c050efcfb4fa68a00ed78
diff --git a/net-analyzer/fragroute/files/fragroute-1.2.6-pcap_open.patch b/net-analyzer/fragroute/files/fragroute-1.2.6-pcap_open.patch
new file mode 100644
index 000000000000..6dedb535d3b5
--- /dev/null
+++ b/net-analyzer/fragroute/files/fragroute-1.2.6-pcap_open.patch
@@ -0,0 +1,44 @@
+--- a/fragtest.c
++++ b/fragtest.c
+@@ -458,7 +458,7 @@
+ if ((ctx.ip = ip_open()) == NULL)
+ err(1, "couldn't open raw IP interface");
+
+- if ((ctx.pcap = pcap_open(ifent.intf_name)) == NULL)
++ if ((ctx.pcap = fragroute_pcap_open(ifent.intf_name)) == NULL)
+ err(1, "couldn't open %s for sniffing", ifent.intf_name);
+
+ if ((ctx.dloff = pcap_dloff(ctx.pcap)) < 0)
+--- a/tun-loop.c
++++ b/tun-loop.c
+@@ -331,7 +331,7 @@
+ return (tun_close(tun));
+
+ /* Set up to sniff on loopback. */
+- if ((tun->pcap = pcap_open(tun->ifent->intf_name)) == NULL)
++ if ((tun->pcap = fragroute_pcap_open(tun->ifent->intf_name)) == NULL)
+ return (tun_close(tun));
+
+ if (pcap_filter(tun->pcap, "ip dst %s", addr_ntoa(dst)) < 0)
+--- a/pcaputil.c
++++ b/pcaputil.c
+@@ -27,7 +27,7 @@
+ #include "pcaputil.h"
+
+ pcap_t *
+-pcap_open(char *device)
++fragroute_pcap_open(char *device)
+ {
+ char ebuf[PCAP_ERRBUF_SIZE];
+ pcap_t *pcap;
+--- a/pcaputil.h
++++ b/pcaputil.h
+@@ -9,7 +9,7 @@
+ #ifndef PCAPUTIL_H
+ #define PCAPUTIL_H
+
+-pcap_t *pcap_open(char *device);
++pcap_t *fragroute_pcap_open(char *device);
+ int pcap_dloff(pcap_t *pcap);
+ int pcap_filter(pcap_t *pcap, const char *fmt, ...);
+
diff --git a/net-analyzer/fragroute/fragroute-1.2.6.ebuild b/net-analyzer/fragroute/fragroute-1.2.6-r1.ebuild
index 480dc836096d..53aaa81ffc3d 100644
--- a/net-analyzer/fragroute/fragroute-1.2.6.ebuild
+++ b/net-analyzer/fragroute/fragroute-1.2.6-r1.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
MY_P="${P}-ipv6"
-inherit autotools-utils
+inherit autotools
DESCRIPTION="Testing of network intrusion detection systems, firewalls and TCP/IP stacks"
HOMEPAGE="https://github.com/stsi/fragroute-ipv6"
@@ -22,26 +20,28 @@ RDEPEND="
net-libs/libpcap
>=dev-libs/libdnet-1.12[ipv6]
"
-DEPEND="${RDEPEND}
- virtual/awk"
-
-S="${WORKDIR}/${MY_P}"
-
+DEPEND="
+ ${RDEPEND}
+ virtual/awk
+"
DOCS=( INSTALL README TODO )
+PATCHES=(
+ "${FILESDIR}"/${P}-pcap_open.patch
+)
+S="${WORKDIR}/${MY_P}"
src_prepare() {
+ default
# Remove broken and old files, autotools will regen needed files
rm *.m4 acconfig.h missing Makefile.in || die
# Add missing includes
sed -i -e "/#define IPUTIL_H/a#include <stdio.h>\n#include <stdint.h>" iputil.h || die
- autotools-utils_src_prepare
+ eautoreconf
}
src_configure() {
- local myeconfargs=(
- --with-libevent="${EPREFIX}"/usr \
+ econf \
--with-libdnet="${EPREFIX}"/usr \
+ --with-libevent="${EPREFIX}"/usr \
--with-libpcap="${EPREFIX}"/usr
- )
- autotools-utils_src_configure
}