summaryrefslogtreecommitdiff
path: root/net-analyzer/fprobe/fprobe-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/fprobe/fprobe-1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/fprobe/fprobe-1.1.ebuild')
-rw-r--r--net-analyzer/fprobe/fprobe-1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/fprobe/fprobe-1.1.ebuild b/net-analyzer/fprobe/fprobe-1.1.ebuild
new file mode 100644
index 000000000000..97dcfe72a52f
--- /dev/null
+++ b/net-analyzer/fprobe/fprobe-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="A libpcap-based tool to collect network traffic data and emit it as NetFlow flows"
+HOMEPAGE="http://fprobe.sourceforge.net"
+LICENSE="GPL-2"
+
+SRC_URI="mirror://sourceforge/fprobe/${P}.tar.bz2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+IUSE="debug messages"
+
+DEPEND="net-libs/libpcap"
+
+src_compile() {
+ local myconf
+ myconf="`use_enable debug`
+ `use_enable messages`"
+
+ econf ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS NEWS README TODO
+ docinto contrib ; dodoc contrib/tg.sh
+}