summaryrefslogtreecommitdiff
path: root/net-analyzer/fprobe/fprobe-1.1-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 15:10:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 15:10:23 +0100
commit27b0740bf48a0a181090a49d20f368ac8474e90b (patch)
treed715e035ea5c7dfe4a21b510e898913c33289cfa /net-analyzer/fprobe/fprobe-1.1-r5.ebuild
parentad0412d0cafb8c04ce98024155cf99a4cc27db44 (diff)
gentoo auto-resync : 30:07:2022 - 15:10:23
Diffstat (limited to 'net-analyzer/fprobe/fprobe-1.1-r5.ebuild')
-rw-r--r--net-analyzer/fprobe/fprobe-1.1-r5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/fprobe/fprobe-1.1-r5.ebuild b/net-analyzer/fprobe/fprobe-1.1-r5.ebuild
new file mode 100644
index 000000000000..1aee1c4aa4f3
--- /dev/null
+++ b/net-analyzer/fprobe/fprobe-1.1-r5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="libpcap-based tool to collect network traffic data and emit it as NetFlow flows"
+HOMEPAGE="http://fprobe.sourceforge.net"
+SRC_URI="mirror://sourceforge/fprobe/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug messages"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/fprobe-1.1-pidfile-sanity.patch
+ "${FILESDIR}"/fprobe-1.1-setgroups.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable messages)
+}
+
+src_install() {
+ default
+
+ docinto contrib
+ dodoc contrib/tg.sh
+
+ newinitd "${FILESDIR}"/init.d-fprobe-r1 fprobe
+ newconfd "${FILESDIR}"/conf.d-fprobe-r1 fprobe
+}