summaryrefslogtreecommitdiff
path: root/net-analyzer/fail2ban
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /net-analyzer/fail2ban
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'net-analyzer/fail2ban')
-rw-r--r--net-analyzer/fail2ban/Manifest4
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.10.4.ebuild115
-rw-r--r--net-analyzer/fail2ban/fail2ban-99999999.ebuild2
3 files changed, 120 insertions, 1 deletions
diff --git a/net-analyzer/fail2ban/Manifest b/net-analyzer/fail2ban/Manifest
index e84a8b50e8e5..f738631b30db 100644
--- a/net-analyzer/fail2ban/Manifest
+++ b/net-analyzer/fail2ban/Manifest
@@ -1,4 +1,6 @@
DIST fail2ban-0.10.3.1.tar.gz 485826 BLAKE2B 79ca86a601bd79ba3729d4c9b00f20a0717df8c7ceb20183099e11f84cceade274173be90d0b4b000d37a1b9d242e14106c9e7e40e372e450d69bca003fff6fb SHA512 ed3646ef2113fe10d9130c239818087b228ac9708411e26acc412beae022e3f9ff8cea32d824bd491117882fb8f184dcb88bda295bd31e865ac8310c7e27fc7a
+DIST fail2ban-0.10.4.tar.gz 493104 BLAKE2B 3a58ab114cf25172c77b229ce53bf6dd009d4fb8c700142480ba0212072d8820126bfabf5dd417835bdac5f5b65d599c6dde859d8c57267e90cfb569dc4a2073 SHA512 ee53f2e8dc3cda4f588c60da5227d3d71550496ddfdf5bdbffced25bafd442b8e2352a9ad9f27bf76489903b5b779cdb9614963342de907c1036ae9268b8f35f
EBUILD fail2ban-0.10.3.1.ebuild 3341 BLAKE2B 0b0f7d1f4ca20d23ef9d787c04bc984e9859900f9e3fec4c691338d6638a32e6e9fa4948ce31895821a7cc4787806051059687864c2cde8fce7f13f26ef0e084 SHA512 63c23a53745ce27797eeb686fb896d3dfaf86b7a1c4a7cfddaf1f2438fef6c44dead638719f884d4ed46fe19d40edd204dad20a0d05121d1646d51a5b4a40e60
-EBUILD fail2ban-99999999.ebuild 3190 BLAKE2B dac84d04dc01c20b5af2a34c07be78ce7db25c79d00a5cfc7e6c58b4077e884b71e8fdb83b34e9abe7326c68836b3963d6ebd373bb618e74db4f13cb7464e086 SHA512 8b2a59c16a2a9bc712c7d905a30df88d72ebf47e5f89e227bd1371ae35aa7d44c6056c1aef7c9952ae166b0bab806e8a21ee584eff36652df43d0cc668f237e5
+EBUILD fail2ban-0.10.4.ebuild 3371 BLAKE2B fb45dfe1c49aa2f04e16c43dbb7164ca61acd0900ddac2f4c94b110b128826a97d4fc13b84396907c98acf84982b294e205d2bf9194830b34cfcfc88c3a3d5f9 SHA512 b12dfa204877368059205bc990e83f3f05aac361c39fc49c1181e9c540b66a1963275058ce9f1147b7bd47555731337422ae9f316451f5df4aa5c0b547220d83
+EBUILD fail2ban-99999999.ebuild 3215 BLAKE2B 8399290d5bfe3ccc696ba20ae5610bdc514defd6bd10ed0065130af0fb6b9283d8b2b60c70b6a58db7fd378d67a37832f6d0ce699d427785f5755524fd1da723 SHA512 ce07e767c99bbcaafa1305d38fea51d19ddd5ff57e215e7ae72d20ef39084a7f8c1a6a8b0d698e7571d6065bce775d2e9a1ceab2829ae4af4ad758c826d93958
MISC metadata.xml 372 BLAKE2B 7fca866187d9a128e6fb6787a4099d7a6442e0e51e558786773b91c3e2f06e67167d76f9bc96be0fe1baa1c44fc3f0e9e2105a327a10cb2720b3e3f9e4303a66 SHA512 4d5710e2fb4a7c353ca6bd3203bceef57d4d004367993dc1044800ee8713a3f4697fe8ba3472a73ecd015503656dfb7cd68d674c99188ce5702769cfeaf06b25
diff --git a/net-analyzer/fail2ban/fail2ban-0.10.4.ebuild b/net-analyzer/fail2ban/fail2ban-0.10.4.ebuild
new file mode 100644
index 000000000000..d17adcb58864
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.10.4.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 eutils systemd vcs-snapshot
+
+DESCRIPTION="scans log files and bans IPs that show malicious signs"
+HOMEPAGE="http://www.fail2ban.org/"
+SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="selinux systemd"
+
+# TODO support ipfw and ipfilter
+RDEPEND="
+ kernel_linux? ( net-firewall/iptables )
+ kernel_FreeBSD? ( sys-freebsd/freebsd-pf )
+ net-misc/whois
+ virtual/logger
+ virtual/mta
+ selinux? ( sec-policy/selinux-fail2ban )
+ systemd? ( $(python_gen_cond_dep '|| (
+ dev-python/python-systemd[${PYTHON_USEDEP}]
+ sys-apps/systemd[python(-),${PYTHON_USEDEP}]
+ )' 'python*' ) )
+"
+
+REQUIRED_USE="systemd? ( !python_single_target_pypy )"
+
+DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
+
+python_prepare_all() {
+ eapply_user
+
+ # Replace /var/run with /run, but not in the top source directory
+ find . -mindepth 2 -type f -exec \
+ sed -i -e 's|/var\(/run/fail2ban\)|\1|g' {} + || die
+
+ sed -i -e 's|runscript|openrc-run|g' files/gentoo-initd || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if python_is_python3; then
+ ./fail2ban-2to3 || die
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ "${PYTHON}" "bin/${PN}-testcases" || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ rm -rf "${D}"/usr/share/doc/${PN} "${D}"/run || die
+
+ # not FILESDIR
+ newconfd files/gentoo-confd ${PN}
+ newinitd files/gentoo-initd ${PN}
+ sed -e "s:@BINDIR@:${EPREFIX}/usr/bin:g" files/${PN}.service.in > "${T}/${PN}.service" || die
+ systemd_dounit "${T}/${PN}.service"
+ systemd_dotmpfilesd files/${PN}-tmpfiles.conf
+ doman man/*.{1,5}
+
+ # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
+ # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
+ insinto /etc/logrotate.d
+ newins files/${PN}-logrotate ${PN}
+
+ keepdir /var/lib/${PN}
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
+
+ if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
+ elog "For most jail.conf configurations, it is recommended you install either"
+ elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
+ elog "to control how log file modifications are detected"
+ fi
+
+ if ! has_version dev-lang/python[sqlite]; then
+ elog "If you want to use ${PN}'s persistent database, then reinstall"
+ elog "dev-lang/python with USE=sqlite"
+ fi
+
+ if has_version sys-apps/systemd[-python]; then
+ elog "If you want to track logins through sys-apps/systemd's"
+ elog "journal backend, then reinstall sys-apps/systemd with USE=python"
+ fi
+}
diff --git a/net-analyzer/fail2ban/fail2ban-99999999.ebuild b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
index c55edd104295..a00563b4c262 100644
--- a/net-analyzer/fail2ban/fail2ban-99999999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
@@ -68,6 +68,8 @@ python_install_all() {
# See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
insinto /etc/logrotate.d
newins files/${PN}-logrotate ${PN}
+
+ keepdir /var/lib/${PN}
}
pkg_preinst() {