summaryrefslogtreecommitdiff
path: root/net-analyzer/ettercap/ettercap-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-25 06:49:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-25 06:49:35 +0000
commit0b82ae29b3034efe3e7b7f533dbcb76168544c5e (patch)
treeea954d341afdcf53b3b79c78c9a54ff2c9693096 /net-analyzer/ettercap/ettercap-9999.ebuild
parentb0b85e141f6a9a74d9d6bdce989a626ff5e92523 (diff)
gentoo auto-resync : 25:03:2023 - 06:49:35
Diffstat (limited to 'net-analyzer/ettercap/ettercap-9999.ebuild')
-rw-r--r--net-analyzer/ettercap/ettercap-9999.ebuild40
1 files changed, 24 insertions, 16 deletions
diff --git a/net-analyzer/ettercap/ettercap-9999.ebuild b/net-analyzer/ettercap/ettercap-9999.ebuild
index b050ccc4f5d7..6514ab4a71fc 100644
--- a/net-analyzer/ettercap/ettercap-9999.ebuild
+++ b/net-analyzer/ettercap/ettercap-9999.ebuild
@@ -1,30 +1,31 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
-DESCRIPTION="A suite for man in the middle attacks"
+DESCRIPTION="Suite for man in the middle attacks"
HOMEPAGE="https://github.com/Ettercap/ettercap"
LICENSE="GPL-2+"
SLOT="0"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Ettercap/${PN}.git"
else
SRC_URI="https://github.com/Ettercap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha amd64 arm ppc ppc64 sparc x86"
fi
IUSE="doc geoip gtk ipv6 ncurses +plugins test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/libbsd
- dev-libs/libpcre
- dev-libs/openssl:0=
+RDEPEND="
+ dev-libs/libbsd
+ dev-libs/libpcre2
+ dev-libs/openssl:=
net-libs/libnet:1.1
>=net-libs/libpcap-0.8.1
sys-libs/zlib
@@ -39,13 +40,19 @@ RDEPEND="dev-libs/libbsd
>=x11-libs/pango-1.2.3
)
ncurses? ( >=sys-libs/ncurses-5.3:= )
- plugins? ( >=net-misc/curl-7.26.0 )"
-DEPEND="${RDEPEND}
- doc? ( app-text/ghostscript-gpl
- sys-apps/groff )
- test? ( dev-libs/check )
+ plugins? ( >=net-misc/curl-7.26.0 )
+"
+DEPEND="
+ app-alternatives/yacc
sys-devel/flex
- app-alternatives/yacc"
+"
+BDEPEND="
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
+ test? ( dev-libs/check )
+"
src_prepare() {
sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
@@ -66,8 +73,9 @@ src_configure() {
-DINSTALL_SYSCONFDIR="${EPREFIX}"/etc
)
+ # right now we only support gtk2, but ettercap also supports gtk3
+ # do we care? do we want to support both?
! use gtk && mycmakeargs+=(-DINSTALL_DESKTOP=OFF)
- #right now we only support gtk2, but ettercap also supports gtk3
- #do we care? do we want to support both?
+
cmake_src_configure
}