summaryrefslogtreecommitdiff
path: root/net-analyzer/ethloop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/ethloop
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/ethloop')
-rw-r--r--net-analyzer/ethloop/Manifest6
-rw-r--r--net-analyzer/ethloop/ethloop-10-r3.ebuild29
-rw-r--r--net-analyzer/ethloop/files/ethloop-10-gcc45.patch32
-rw-r--r--net-analyzer/ethloop/metadata.xml9
4 files changed, 76 insertions, 0 deletions
diff --git a/net-analyzer/ethloop/Manifest b/net-analyzer/ethloop/Manifest
new file mode 100644
index 000000000000..fd2f848b4d94
--- /dev/null
+++ b/net-analyzer/ethloop/Manifest
@@ -0,0 +1,6 @@
+AUX ethloop-10-gcc45.patch 784 SHA256 e9bae29f4073831786ef9ddcef5a75e542ae1fe9319e97e269332723582cf44e SHA512 213978c89fca49f82c47322e91a4ba6a72b92b711b9386de9833b7330e6fa9fb5668d658968669c1eeeddae96a74c32a086ad630410b9c3b8e153a19e720c036 WHIRLPOOL 381102c20a1e8cd393942b75ae6228639fc45dcb02acac93ff15bb80a2bd10999d50da041d2adb1920df376d37ea53498313019973f62724e1b9a0fdccfcf6f9
+DIST ethloop10.tgz 3912 SHA256 d1f7b4500946dc6c0e6fe031fcebc789d9e061645cd775fe4005820a75039b86 SHA512 82ac0114d0d539f5c057101e1e1f0e2eac32e0bd482bd62e6305f7c4863d0776dcff7bc85167dbcfb136d0b430c9008241c2c0250713beb2703cb052b9b71e63 WHIRLPOOL aa0af08ce518c38bf44ea639f5a4466a4d68e1dd1cc2c2b28283f6e8b4fd27f00a157f5ce80a45a6e46f8c0d916f44f675889e0253509639be36bf1d451a4336
+EBUILD ethloop-10-r3.ebuild 592 SHA256 1180299a89b9cdce6127fab8a5bbd616ad339ec85d8c1447f9ca56ba5b4c922a SHA512 5e5761dc8ccb7bbe860372ec80ce9c5eb94775a9f4ea62ad7395276e5878d21ccb85b1c990d9a7d1baf4d2e4389532a81e9e0f5ec7204d0264ab73229fef8e34 WHIRLPOOL 5132bec0c7651a39b63b555897cb185fdd1bf5ea7be190b485a79c5e5fe96808b95a2db7b1025e22b42235c6545e2839b4f5af8a29fc46cddc03f5930dc77173
+MISC ChangeLog 2462 SHA256 6877dab07c455ff1d99d38a6723d84f2bb2a1e32281f79771167bf6984fc82ee SHA512 9ee96cbfa2c331aea0ba5011cf650229f0e8357657bf3a5aec92285eb12c73cf296f7126553570c9cb9413aa37f2137b898c6fb4e5191f975b9d0c126906e8e5 WHIRLPOOL 61ef80a0e3e9577b4e8e973d47a0df66fc082de31f8e3c1abf8f25d2f96a32a18aafc7f57807e46c10615d4827cd07c07d96317156ac31b82ea740f34173eef3
+MISC ChangeLog-2015 1919 SHA256 77420a42880576ec005fa9765c3fbd990b1739beb9a8dfe5cce393afa846a2e0 SHA512 7a6af5d97bf8f5c4ddc16e3f08a11735be7671f2e4dce4025c8e637fe267966acbea5a039c4b7d6a2b17977d2e12d735b1ffaeb8e8ef98ade94ea9cdc41963fe WHIRLPOOL 9ba8491d98fa458c1b17d844e32f52665b68823d81232154ee5b82eafe136a9fdaf188274e1ca8b1c28ff156068ae2089dcb66a1067168464962671f94523402
+MISC metadata.xml 361 SHA256 6e78ff41b493d746ee5bc4378b97687318d4a9aaa2404118aae6f6d30190f0fd SHA512 a4572b46f20688c9d75c5aa555bf051f3416b8992e0c2358f4594be215571f356575441d4e45b2785af0c6c5c5c2d8862f2fd48202cc528ccda3a9e8ba69c214 WHIRLPOOL 2f49391248c1e1c8d0668d1498b414db0ea0e49acda7022c7fb1c39840c3092a6afebd387d3b53fa62b19b911ae779a4accb8f91d8121df3915e548973803dcd
diff --git a/net-analyzer/ethloop/ethloop-10-r3.ebuild b/net-analyzer/ethloop/ethloop-10-r3.ebuild
new file mode 100644
index 000000000000..d49ae392f80f
--- /dev/null
+++ b/net-analyzer/ethloop/ethloop-10-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Local simulator for testing Linux QoS disciplines"
+HOMEPAGE="http://luxik.cdi.cz/~devik/qos/ethloop/"
+SRC_URI="http://luxik.cdi.cz/~devik/qos/ethloop/ethloop10.tgz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dosbin ethloop
+}
diff --git a/net-analyzer/ethloop/files/ethloop-10-gcc45.patch b/net-analyzer/ethloop/files/ethloop-10-gcc45.patch
new file mode 100644
index 000000000000..75b951102245
--- /dev/null
+++ b/net-analyzer/ethloop/files/ethloop-10-gcc45.patch
@@ -0,0 +1,32 @@
+Fix recv call (bug #336755), add some more includes.
+
+--- a/ethloop.c 2002-05-03 15:13:20.000000000 +0200
++++ b/ethloop.c 2010-12-27 18:21:24.000000000 +0100
+@@ -1,5 +1,7 @@
+ /* vim: cin sw=4 ts=4
+ */
++#include <arpa/inet.h> /* htons() */
++#include <sys/types.h> /* recv() */
+ #include <sys/socket.h>
+ #include <sys/ioctl.h>
+ #include <sys/poll.h>
+@@ -13,6 +15,7 @@
+ #include <stdlib.h>
+ #include <sys/time.h>
+ #include <signal.h>
++#include <string.h>
+
+ int sock;
+
+@@ -133,9 +136,9 @@
+ int recv_raw(int tmo)
+ {
+ struct pollfd pf = {sock,POLLIN,0};
+- int r; unsigned short proto;
++ ssize_t r; unsigned short proto;
+ if(poll(&pf,1,tmo) <= 0) return 0;
+- r = recv(sock,&buf,1550,0);
++ r = recv(sock,&buf,sizeof(buf),0);
+ if (r <= 0) {
+ printf("error recv (%d)\n",r);
+ return 0;
diff --git a/net-analyzer/ethloop/metadata.xml b/net-analyzer/ethloop/metadata.xml
new file mode 100644
index 000000000000..497a26fb249e
--- /dev/null
+++ b/net-analyzer/ethloop/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>netmon@gentoo.org</email>
+ <name>Gentoo network monitoring and analysis project</name>
+</maintainer>
+<longdescription>Local simulator for testing Linux QoS disciplines</longdescription>
+</pkgmetadata>