summaryrefslogtreecommitdiff
path: root/net-analyzer/ethloop/ethloop-10-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-analyzer/ethloop/ethloop-10-r4.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-analyzer/ethloop/ethloop-10-r4.ebuild')
-rw-r--r--net-analyzer/ethloop/ethloop-10-r4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/ethloop/ethloop-10-r4.ebuild b/net-analyzer/ethloop/ethloop-10-r4.ebuild
new file mode 100644
index 000000000000..4067bea8c944
--- /dev/null
+++ b/net-analyzer/ethloop/ethloop-10-r4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Local simulator for testing Linux QoS disciplines"
+HOMEPAGE="http://luxik.cdi.cz/~devik/qos/ethloop/"
+SRC_URI="http://luxik.cdi.cz/~devik/qos/${PN}/${PN}${PV}.tgz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}
+PATCHES=(
+ "${FILESDIR}"/${P}-misc.patch
+)
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dosbin ethloop
+}