summaryrefslogtreecommitdiff
path: root/net-analyzer/dsniff/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /net-analyzer/dsniff/files
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'net-analyzer/dsniff/files')
-rw-r--r--net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-httppostfix.patch21
-rw-r--r--net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-libdir-configure.patch105
-rw-r--r--net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-respect-AR.patch22
3 files changed, 148 insertions, 0 deletions
diff --git a/net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-httppostfix.patch b/net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-httppostfix.patch
new file mode 100644
index 000000000000..487e45321662
--- /dev/null
+++ b/net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-httppostfix.patch
@@ -0,0 +1,21 @@
+Allow mixed case in some fields.
+--- a/decode_http.c
++++ b/decode_http.c
+@@ -139,14 +139,14 @@
+ host = p;
+ }
+ else if (req[0] == 'P') {
+- if (strncmp(p, "Content-type: ", 14) == 0) {
+- if (strncmp(p + 14, "application/"
++ if (strncasecmp(p, "Content-type: ", 14) == 0) {
++ if (strncasecmp(p + 14, "application/"
+ "x-www-form-urlencoded",
+ 33) != 0) {
+ query = NULL;
+ }
+ }
+- else if (strncmp(p, "Content-length: ", 16) == 0) {
++ else if (strncasecmp(p, "Content-length: ", 16) == 0) {
+ p += 16;
+ i = atoi(p);
+ if ((msg = buf_tok(&inbuf, NULL, i)) == NULL)
diff --git a/net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-libdir-configure.patch b/net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-libdir-configure.patch
new file mode 100644
index 000000000000..a2309cd836e8
--- /dev/null
+++ b/net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-libdir-configure.patch
@@ -0,0 +1,105 @@
+Respect libdir rather than always using 'lib'.
+--- a/configure.in
++++ b/configure.in
+@@ -127,13 +127,13 @@ AC_ARG_WITH(db,
+ if test -f ${dir}/include/db_185.h; then
+ AC_DEFINE(HAVE_DB_185_H)
+ DBINC="-I${dir}/include"
+- DBLIB="-L${dir}/lib -ldb"
++ DBLIB="-L${dir}/${libdir#${prefix}} -ldb"
+ have_db=yes
+ break
+ elif test -f ${dir}/include/db.h; then
+ AC_DEFINE(HAVE_DB_H)
+ DBINC="-I${dir}/include"
+- DBLIB="-L${dir}/lib -ldb"
++ DBLIB="-L${dir}/${libdir#${prefix}} -ldb"
+ have_db=yes
+ break
+ fi
+@@ -178,11 +178,11 @@ AC_ARG_WITH(libpcap,
+ PCAPLIB="-L$withval -lpcap"
+ elif test -f $withval/include/pcap.h -a \
+ -f $withval/include/net/bpf.h -a \
+- -f $withval/lib/libpcap.a; then
++ -f $withval/${libdir#${prefix}}/libpcap.a; then
+ owd=`pwd`
+ if cd $withval; then withval=`pwd`; cd $owd; fi
+ PCAPINC="-I$withval/include"
+- PCAPLIB="-L$withval/lib -lpcap"
++ PCAPLIB="-L$withval/${libdir#${prefix}} -lpcap"
+ else
+ AC_ERROR(pcap.h, net/bpf.h, or libpcap.a not found in $withval)
+ fi
+@@ -190,7 +190,7 @@ AC_ARG_WITH(libpcap,
+ esac ],
+ [ if test -f ${prefix}/include/pcap.h; then
+ PCAPINC="-I${prefix}/include"
+- PCAPLIB="-L${prefix}/lib -lpcap"
++ PCAPLIB="-L${prefix}/${libdir#${prefix}} -lpcap"
+ elif test -f /usr/include/pcap/pcap.h; then
+ PCAPINC="-I/usr/include/pcap"
+ PCAPLIB="-lpcap"
+@@ -226,7 +226,7 @@ AC_ARG_WITH(libnet,
+ CFLAGS="$CFLAGS `libnet-config --defines`"
+ fi
+ LNETINC="-I$withval/include"
+- LNETLIB="-L$withval/lib -lnet"
++ LNETLIB="-L$withval/${libdir#${prefix}} -lnet"
+ else
+ AC_ERROR(libnet.h or libnet.a not found in $withval)
+ fi
+@@ -235,7 +235,7 @@ AC_ARG_WITH(libnet,
+ [ if test -f ${prefix}/include/libnet.h; then
+ CFLAGS="$CFLAGS `${prefix}/bin/libnet-config --defines`"
+ LNETINC="-I${prefix}/include"
+- LNETLIB="-L${prefix}/lib -lnet"
++ LNETLIB="-L${prefix}/${libdir#${prefix}} -lnet"
+ elif test -f /usr/include/libnet.h; then
+ CFLAGS="$CFLAGS `libnet-config --defines`"
+ LNETLIB="-lnet"
+@@ -267,7 +267,7 @@ AC_ARG_WITH(libnids,
+ owd=`pwd`
+ if cd $withval; then withval=`pwd`; cd $owd; fi
+ NIDSINC="-I$withval/include"
+- NIDSLIB="-L$withval/lib -lnids"
++ NIDSLIB="-L$withval/${libdir#${prefix}} -lnids"
+ else
+ AC_ERROR(nids.h or libnids.a not found in $withval)
+ fi
+@@ -275,7 +275,7 @@ AC_ARG_WITH(libnids,
+ esac ],
+ [ if test -f ${prefix}/include/nids.h; then
+ NIDSINC="-I${prefix}/include"
+- NIDSLIB="-L${prefix}/lib -lnids"
++ NIDSLIB="-L${prefix}/${libdir#${prefix}} -lnids"
+ elif test -f /usr/include/nids.h; then
+ NIDSLIB="-lnids"
+ else
+@@ -309,11 +309,11 @@ AC_ARG_WITH(openssl,
+ SSLINC="-I$withval/include"
+ SSLLIB="-L$withval -lssl -lcrypto"
+ elif test -f $withval/include/openssl/ssl.h -a \
+- -f $withval/lib/libssl.a; then
++ -f $withval/${libdir#${prefix}}/libssl.a; then
+ owd=`pwd`
+ if cd $withval; then withval=`pwd`; cd $owd; fi
+ SSLINC="-I$withval/include"
+- SSLLIB="-L$withval/lib -lssl -lcrypto"
++ SSLLIB="-L$withval/${libdir#${prefix}} -lssl -lcrypto"
+ else
+ AC_ERROR(ssl.h or libssl.a not found in $withval)
+ fi
+@@ -322,10 +322,10 @@ AC_ARG_WITH(openssl,
+ esac ],
+ [ if test -f ${prefix}/include/openssl/ssl.h; then
+ SSLINC="-I${prefix}/include"
+- SSLLIB="-L${prefix}/lib -lssl -lcrypto"
++ SSLLIB="-L${prefix}/${libdir#${prefix}} -lssl -lcrypto"
+ elif test -f ${prefix}/ssl/include/openssl/ssl.h; then
+ SSLINC="-I${prefix}/ssl/include"
+- SSLLIB="-L${prefix}/ssl/lib -lssl -lcrypto"
++ SSLLIB="-L${prefix}/ssl/${libdir#${prefix}} -lssl -lcrypto"
+ elif test -f /usr/include/openssl/ssl.h; then
+ SSLLIB="-lssl -lcrypto"
+ else
diff --git a/net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-respect-AR.patch b/net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-respect-AR.patch
new file mode 100644
index 000000000000..fd2235fada7d
--- /dev/null
+++ b/net-analyzer/dsniff/files/dsniff-2.4_beta1_p30-respect-AR.patch
@@ -0,0 +1,22 @@
+Respect the 'AR' environment variable.
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -103,7 +103,7 @@ $(LIBOBJS):
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(INCS) -c $(srcdir)/missing/$*.c
+
+ libmissing.a: $(LIBOBJS)
+- ar -cr $@ $(LIBOBJS)
++ $(AR) -cr $@ $(LIBOBJS)
+ $(RANLIB) $@
+
+ dsniff: $(HDRS) $(SRCS) $(OBJS) libmissing.a
+--- a/configure.in
++++ b/configure.in
+@@ -17,6 +17,7 @@ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
++AC_CHECK_PROG(AR,ar,ar)
+
+ dnl Checks for header files.
+ AC_PATH_XTRA