summaryrefslogtreecommitdiff
path: root/net-analyzer/cbm/cbm-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /net-analyzer/cbm/cbm-0.3.1.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'net-analyzer/cbm/cbm-0.3.1.ebuild')
-rw-r--r--net-analyzer/cbm/cbm-0.3.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/cbm/cbm-0.3.1.ebuild b/net-analyzer/cbm/cbm-0.3.1.ebuild
new file mode 100644
index 000000000000..22ae3162bb6a
--- /dev/null
+++ b/net-analyzer/cbm/cbm-0.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Color Bandwidth Meter"
+HOMEPAGE="
+ http://www.isotton.com/software/unix/cbm/
+ https://github.com/resurrecting-open-source-projects/cbm
+"
+SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="app-text/docbook-xml-dtd:4.4
+ app-text/xmlto
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}