summaryrefslogtreecommitdiff
path: root/net-analyzer/bwm-ng/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/bwm-ng/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/bwm-ng/files')
-rw-r--r--net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch93
-rw-r--r--net-analyzer/bwm-ng/files/bwm-ng-0.6.1-static-inline.patch256
2 files changed, 349 insertions, 0 deletions
diff --git a/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch b/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch
new file mode 100644
index 000000000000..04c14392d66a
--- /dev/null
+++ b/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch
@@ -0,0 +1,93 @@
+* Fix broken buildsystem
+* Fix ncurses underlinking caused by missing "-ltinfo" in $LIBS
+https://bugs.gentoo.org/show_bug.cgi?id=561718
+
+--- a/configure.in
++++ b/configure.in
+@@ -3,7 +3,7 @@
+
+ AC_INIT([bwm-ng],[0.6.1],[bwmng@gropp.org],[bwm-ng])
+ AC_CONFIG_SRCDIR(src/bwm-ng.c)
+-AM_INIT_AUTOMAKE([gnu])
++AM_INIT_AUTOMAKE([gnu subdir-objects])
+ AC_CONFIG_HEADERS(config.h)
+ AC_CONFIG_MACRO_DIR(./)
+ AC_LANG([C])
+@@ -28,44 +28,12 @@
+ AC_CHECK_TYPES(unsigned long long)
+
+ # Checks for libraries.
+-CURSES_CHECKED="0"
++AC_ARG_ENABLE([ncurses],
++ AS_HELP_STRING([--enable-ncurses], [Enable feature ncurses]))
+
+-AC_ARG_WITH([curses],AS_HELP_STRING([--with-curses],[with curses (ARG=PATH)]),[
+-if [ test $withval != "no" ]; then
+- OLD_CPPFLAGS=$CPPFLAGS
+- if [ test $withval != "yes" ]; then
+- CPPFLAGS="$CPPFLAGS -I$withval"
+- fi
+- AC_CHECK_LIB([curses],[newterm,timeout],,[ CPPFLAGS=$OLD_CPPFLAGS ])
+- CURSES_CHECKED="1"
+-else
+- CURSES_CHECKED="1"
+-fi
+-])
+-
+-
+-if [ test $CURSES_CHECKED != "1" ]; then
+-AC_ARG_WITH([ncurses],AS_HELP_STRING([--with-ncurses],[prefer ncurses over curses (ARG=PATH)]),[
+-if [ test $withval != "no" ]; then
+- OLD_CPPFLAGS=$CPPFLAGS
+- if [ test $withval != "yes" ]; then
+- CPPFLAGS="$CPPFLAGS -I$withval"
+- fi
+- AC_CHECK_LIB([ncurses],[newterm,timeout],,[ CPPFLAGS=$OLD_CPPFLAGS ])
+- CURSES_CHECKED="1"
+-else
+- CURSES_CHECKED="1"
+-fi
++AS_IF([test "x$enable_ncurses" != "xno"], [
++ PKG_CHECK_MODULES([NCURSES], [ncurses], [AC_DEFINE([HAVE_LIBNCURSES], [1], [Define to 1 if you have the `ncurses' library (-lncurses).])])
+ ])
+-fi
+-
+-
+-
+-if [ test $CURSES_CHECKED != "1" ]; then
+-AC_CHECK_LIB([curses],[initscr,timeout],,[
+- AC_CHECK_LIB([ncurses],[newterm,timeout])
+-])
+-fi
+
+ AC_CHECK_FUNCS([wattron])
+ AC_CHECK_FUNCS([curs_set])
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -2,12 +2,10 @@
+
+ bin_PROGRAMS = bwm-ng
+
+-bwm_ng_SOURCES = bwm-ng.c process.c output.c options.c help.c curses_tools.c
++bwm_ng_SOURCES = bwm-ng.c process.c output.c options.c help.c curses_tools.c input/retrieve.c input/devstat.c input/libkstat.c input/netstat.c input/proc_net_dev.c input/sysctl.c input/ioservice.c input/libstatgrab.c input/proc_diskstats.c input/win32.c input/getifaddrs.c
+
+-EXTRA_bwm_ng_SOURCES = input/retrieve.c input/devstat.c input/libkstat.c input/netstat.c input/proc_net_dev.c input/sysctl.c input/ioservice.c input/libstatgrab.c input/proc_diskstats.c input/win32.c input/getifaddrs.c
+-
+-bwm_ng_LDADD = retrieve.$(OBJEXT) $(INPUT_SYSTEM)
+-bwm_ng_DEPENDENCIES = retrieve.$(OBJEXT) $(INPUT_SYSTEM)
++bwm_ng_CPPFLAGS = @NCURSES_CFLAGS@
++bwm_ng_LDADD = @NCURSES_LIBS@
+
+ noinst_HEADERS = bwm-ng.h process.h output.h options.h help.h curses_tools.h types.h defines.h global_vars.h input/devstat.h input/libkstat.h input/netstat.h input/proc_net_dev.h input/sysctl.h input/ioservice.h input/libstatgrab.h input/proc_diskstats.h input/retrieve.h input/win32.h input/getifaddrs.h
+
+--- a/src/defines.h
++++ b/src/defines.h
+@@ -48,7 +48,7 @@
+ #define LIBSTATGRAB
+ #endif
+
+-#if HAVE_LIBCURSES || HAVE_LIBNCURSES
++#if defined(HAVE_LIBCURSES) || defined(HAVE_LIBNCURSES)
+ #define HAVE_CURSES
+ #endif
+
diff --git a/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-static-inline.patch b/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-static-inline.patch
new file mode 100644
index 000000000000..88e15ecefe3f
--- /dev/null
+++ b/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-static-inline.patch
@@ -0,0 +1,256 @@
+Make all 'inline' functions 'static inline' such that
+the compiler can emit definitions when needed.
+http://www.greenend.org.uk/rjk/tech/inline.html
+
+--- a/src/bwm-ng.c
++++ b/src/bwm-ng.c
+@@ -26,7 +26,7 @@
+
+ /* handle interrupt signal */
+ void sigint(int sig) FUNCATTR_NORETURN;
+-inline void init(void);
++static inline void init(void);
+
+ /* clear stuff and exit */
+ #ifdef __STDC__
+@@ -98,7 +98,7 @@
+ deinit(0, NULL);
+ }
+
+-inline void init(void) {
++static inline void init(void) {
+ if_count=0;
+ delay=500;
+ #if EXTENDED_STATS
+--- a/src/help.c
++++ b/src/help.c
+@@ -24,9 +24,9 @@
+ #include "global_vars.h"
+ #include "help.h"
+
+-inline void print_help_line(const char *short_c,const char * long_c,const char *descr);
++static inline void print_help_line(const char *short_c,const char * long_c,const char *descr);
+
+-inline void print_help_line(const char *short_c,const char * long_c,const char *descr) {
++static inline void print_help_line(const char *short_c,const char * long_c,const char *descr) {
+ #ifdef LONG_OPTIONS
+ printf(" %-23s",long_c);
+ #else
+--- a/src/options.c
++++ b/src/options.c
+@@ -30,12 +30,12 @@
+ char *trim_whitespace(char *str);
+ int read_config(const char *config_file);
+ #endif
+-inline int str2output_unit(char *optarg);
++static inline int str2output_unit(char *optarg);
+ #if EXTENDED_STATS
+-inline int str2output_type(char *optarg);
++static inline int str2output_type(char *optarg);
+ #endif
+-inline int str2out_method(char *optarg);
+-inline int str2in_method(char *optarg);
++static inline int str2out_method(char *optarg);
++static inline int str2in_method(char *optarg);
+
+ #ifdef CONFIG_FILE
+ /******************************************************************************
+@@ -65,7 +65,7 @@
+ /******************************************************************************/
+ #endif
+
+-inline int str2output_unit(char *optarg) {
++static inline int str2output_unit(char *optarg) {
+ if (optarg) {
+ if (!strcasecmp(optarg,"bytes")) return BYTES_OUT;
+ if (!strcasecmp(optarg,"bits")) return BITS_OUT;
+@@ -76,7 +76,7 @@
+ }
+
+ #if EXTENDED_STATS
+-inline int str2output_type(char *optarg) {
++static inline int str2output_type(char *optarg) {
+ if (optarg) {
+ if (!strcasecmp(optarg,"rate")) return RATE_OUT;
+ if (!strcasecmp(optarg,"max")) return MAX_OUT;
+@@ -87,7 +87,7 @@
+ }
+ #endif
+
+-inline int str2out_method(char *optarg) {
++static inline int str2out_method(char *optarg) {
+ if (optarg) {
+ if (!strcasecmp(optarg,"plain")) return PLAIN_OUT;
+ #ifdef HAVE_CURSES
+@@ -109,7 +109,7 @@
+ }
+
+
+-inline int str2in_method(char *optarg) {
++static inline int str2in_method(char *optarg) {
+ if (optarg) {
+ #ifdef PROC_NET_DEV
+ if (!strcasecmp(optarg,"proc")) return PROC_IN;
+--- a/src/output.c
++++ b/src/output.c
+@@ -25,13 +25,13 @@
+ #include "output.h"
+
+ inline static const char *output_type2str(void);
+-inline const char *input2str(void);
+-inline const char *show_all_if2str(void);
+-inline ullong direction2value(char mode,struct inout_long stats);
++static inline const char *input2str(void);
++static inline const char *show_all_if2str(void);
++static inline ullong direction2value(char mode,struct inout_long stats);
+ #if EXTENDED_STATS
+-inline double direction_max2value(char mode,struct inouttotal_double stats,int items);
++static inline double direction_max2value(char mode,struct inouttotal_double stats,int items);
+ #endif
+-inline char *dyn_byte_value2str(double value,char *str,int buf_size);
++static inline char *dyn_byte_value2str(double value,char *str,int buf_size);
+ char *values2str(char mode,t_iface_speed_stats stats,t_iface_stats full_stats,float multiplier,char *str,int buf_size);
+
+ inline static const char *output_type2str(void) {
+@@ -59,7 +59,7 @@
+ }
+
+
+-inline const char *input2str(void) {
++static inline const char *input2str(void) {
+ switch (input_method) {
+ #ifdef SYSCTL
+ case SYSCTL_IN:
+@@ -121,7 +121,7 @@
+ return "";
+ }
+
+-inline const char *show_all_if2str(void) {
++static inline const char *show_all_if2str(void) {
+ switch (show_all_if) {
+ case 1:
+ return " (all)";
+@@ -262,7 +262,7 @@
+ }
+
+
+-inline ullong direction2value(char mode,struct inout_long stats) {
++static inline ullong direction2value(char mode,struct inout_long stats) {
+ switch (mode) {
+ case 0:
+ return stats.in;
+@@ -275,7 +275,7 @@
+ }
+
+ #if EXTENDED_STATS
+-inline double direction_max2value(char mode,struct inouttotal_double stats,int items) {
++static inline double direction_max2value(char mode,struct inouttotal_double stats,int items) {
+ switch (mode) {
+ case 0:
+ return (double)(stats.in/items);
+@@ -288,7 +288,7 @@
+ }
+ #endif
+
+-inline char *dyn_byte_value2str(double value,char *str,int buf_size) {
++static inline char *dyn_byte_value2str(double value,char *str,int buf_size) {
+ if (dynamic) {
+ if (value<1024)
+ snprintf(str,buf_size,"%15.2f ",value);
+@@ -306,7 +306,7 @@
+ return str;
+ }
+
+-inline char *dyn_bit_value2str(double value,char *str,int buf_size) {
++static inline char *dyn_bit_value2str(double value,char *str,int buf_size) {
+ if (dynamic) {
+ if (value<1000)
+ snprintf(str,buf_size,"%15.2f ",value);
+--- a/src/process.c
++++ b/src/process.c
+@@ -26,19 +26,19 @@
+
+ short show_iface(char *instr, char *searchstr,char iface_is_up);
+ #if HAVE_GETTIMEOFDAY
+-inline long tvdiff(struct timeval newer, struct timeval older);
++static inline long tvdiff(struct timeval newer, struct timeval older);
+ float get_time_delay(int iface_num);
+ #endif
+-inline ullong calc_new_values(ullong new, ullong old);
++static inline ullong calc_new_values(ullong new, ullong old);
+ t_iface_speed_stats convert2calced_values(t_iface_speed_stats new, t_iface_speed_stats old);
+ t_iface_speed_stats convert2calced_disk_values(t_iface_speed_stats new, t_iface_speed_stats old);
+ #if EXTENDED_STATS
+-inline void sub_avg_values(struct inouttotal_double *values,struct inouttotal_double data);
+-inline void add_avg_values(struct inouttotal_double *values,struct inouttotal_double data);
+-inline void save_avg_values(struct inouttotal_double *values,struct inouttotal_double *data,struct inout_long calced_stats,float multiplier);
++static inline void sub_avg_values(struct inouttotal_double *values,struct inouttotal_double data);
++static inline void add_avg_values(struct inouttotal_double *values,struct inouttotal_double data);
++static inline void save_avg_values(struct inouttotal_double *values,struct inouttotal_double *data,struct inout_long calced_stats,float multiplier);
+ void save_avg(struct t_avg *avg,struct iface_speed_stats calced_stats,float multiplier);
+-inline void save_sum(struct inout_long *stats,struct inout_long new_stats_values);
+-inline void save_max(struct inouttotal_double *stats,struct inout_long calced_stats,float multiplier);
++static inline void save_sum(struct inout_long *stats,struct inout_long new_stats_values);
++static inline void save_max(struct inouttotal_double *stats,struct inout_long calced_stats,float multiplier);
+ #endif
+
+ /* returns the whether to show the iface or not
+@@ -74,7 +74,7 @@
+
+ #if HAVE_GETTIMEOFDAY
+ /* Returns: the time difference in milliseconds. */
+-inline long tvdiff(struct timeval newer, struct timeval older) {
++static inline long tvdiff(struct timeval newer, struct timeval older) {
+ return labs((newer.tv_sec-older.tv_sec)*1000+
+ (newer.tv_usec-older.tv_usec)/1000);
+ }
+@@ -92,7 +92,7 @@
+ #endif
+
+ /* basically new-old, but handles "overflow" of source aswell */
+-inline ullong calc_new_values(ullong new, ullong old) {
++static inline ullong calc_new_values(ullong new, ullong old) {
+ /* FIXME: WRAP_AROUND _might_ be wrong for libstatgrab, where the type is always long long */
+ return (new>=old) ? (ullong)(new-old) : (ullong)((
+ #ifdef HAVE_LIBKSTAT
+@@ -133,13 +133,13 @@
+
+ #if EXTENDED_STATS
+ /* sub old values from cached for avg stats */
+-inline void sub_avg_values(struct inouttotal_double *values,struct inouttotal_double data) {
++static inline void sub_avg_values(struct inouttotal_double *values,struct inouttotal_double data) {
+ values->in-=data.in;
+ values->out-=data.out;
+ values->total-=data.total;
+ }
+
+-inline void add_avg_values(struct inouttotal_double *values,struct inouttotal_double data) {
++static inline void add_avg_values(struct inouttotal_double *values,struct inouttotal_double data) {
+ values->in+=data.in;
+ values->out+=data.out;
+ values->total+=data.total;
+@@ -148,7 +148,7 @@
+
+ /* put new-old bytes in inout_long struct into a inouttotal_double struct
+ * and add values to cached .value struct */
+-inline void save_avg_values(struct inouttotal_double *values,struct inouttotal_double *data,struct inout_long calced_stats,float multiplier) {
++static inline void save_avg_values(struct inouttotal_double *values,struct inouttotal_double *data,struct inout_long calced_stats,float multiplier) {
+ data->in=calced_stats.in*multiplier;
+ data->out=calced_stats.out*multiplier;
+ data->total=(calced_stats.in+calced_stats.out)*multiplier;
+@@ -198,13 +198,13 @@
+ }
+
+ /* add current in and out bytes to totals struct */
+-inline void save_sum(struct inout_long *stats,struct inout_long new_stats_values) {
++static inline void save_sum(struct inout_long *stats,struct inout_long new_stats_values) {
+ stats->in+=new_stats_values.in;
+ stats->out+=new_stats_values.out;
+ }
+
+ /* lookup old max values and save new if higher */
+-inline void save_max(struct inouttotal_double *stats,struct inout_long calced_stats,float multiplier) {
++static inline void save_max(struct inouttotal_double *stats,struct inout_long calced_stats,float multiplier) {
+ if (multiplier*calced_stats.in > stats->in)
+ stats->in=multiplier*calced_stats.in;
+ if (multiplier*calced_stats.out>stats->out)