summaryrefslogtreecommitdiff
path: root/net-analyzer/bsnmp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/bsnmp/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/bsnmp/files')
-rw-r--r--net-analyzer/bsnmp/files/bsnmp-1.10-gcc34.patch12
-rw-r--r--net-analyzer/bsnmp/files/bsnmp-1.12-mibII.patch13
-rw-r--r--net-analyzer/bsnmp/files/bsnmpd.init11
-rw-r--r--net-analyzer/bsnmp/files/snmpd.config98
-rw-r--r--net-analyzer/bsnmp/files/werror.patch11
5 files changed, 145 insertions, 0 deletions
diff --git a/net-analyzer/bsnmp/files/bsnmp-1.10-gcc34.patch b/net-analyzer/bsnmp/files/bsnmp-1.10-gcc34.patch
new file mode 100644
index 000000000000..f1220b83d521
--- /dev/null
+++ b/net-analyzer/bsnmp/files/bsnmp-1.10-gcc34.patch
@@ -0,0 +1,12 @@
+diff -ur -x '*~' bsnmp-1.10/snmp_ntp/snmp_ntp.c bsnmp-1.10-fix/snmp_ntp/snmp_ntp.c
+--- bsnmp-1.10/snmp_ntp/snmp_ntp.c 2005-05-23 11:03:48.000000000 +0200
++++ bsnmp-1.10-fix/snmp_ntp/snmp_ntp.c 2005-07-10 01:58:35.557888936 +0200
+@@ -360,6 +360,8 @@
+ free(rpkt);
+ return (-1);
+ }
++
++ return (-1);
+ }
+
+ /*
diff --git a/net-analyzer/bsnmp/files/bsnmp-1.12-mibII.patch b/net-analyzer/bsnmp/files/bsnmp-1.12-mibII.patch
new file mode 100644
index 000000000000..c93191823d6e
--- /dev/null
+++ b/net-analyzer/bsnmp/files/bsnmp-1.12-mibII.patch
@@ -0,0 +1,13 @@
+diff --git a/snmp_mibII/Makefile.in b/snmp_mibII/Makefile.in
+index d14c179..3a99850 100755
+--- a/snmp_mibII/Makefile.in
++++ b/snmp_mibII/Makefile.in
+@@ -10,7 +10,7 @@ MOD= mibII
+ SRCS= ${MOD}_tree.c mibII.c mibII_ifmib.c mibII_ip.c \
+ mibII_interfaces.c mibII_ipaddr.c mibII_ifstack.c \
+ mibII_rcvaddr.c mibII_nettomedia.c mibII_tcp.c mibII_udp.c \
+- mibII_route.c
++ mibII_route.c mibII_begemot.c
+ INCS= snmp_${MOD}.h
+ DEFS= mibII_tree.def
+ MAN3= snmp_mibII.3
diff --git a/net-analyzer/bsnmp/files/bsnmpd.init b/net-analyzer/bsnmp/files/bsnmpd.init
new file mode 100644
index 000000000000..947e542a0437
--- /dev/null
+++ b/net-analyzer/bsnmp/files/bsnmpd.init
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Mini-SNMP Daemon"
+command="/usr/bin/bsnmpd"
+pidfile="/var/run/snmpd.pid"
+
+depend() {
+ use net
+}
diff --git a/net-analyzer/bsnmp/files/snmpd.config b/net-analyzer/bsnmp/files/snmpd.config
new file mode 100644
index 000000000000..26f9f1aeb163
--- /dev/null
+++ b/net-analyzer/bsnmp/files/snmpd.config
@@ -0,0 +1,98 @@
+# $FreeBSD: src/etc/snmpd.config,v 1.9.10.1.8.1 2012/03/03 06:15:13 kensmith Exp $
+#
+# Example configuration file for bsnmpd(1).
+#
+
+#
+# Set some common variables
+#
+location := "Room 200"
+contact := "sysmeister@example.com"
+system := 1 # FreeBSD
+traphost := localhost
+trapport := 162
+
+# Change this!
+read := "public"
+# Uncomment begemotSnmpdCommunityString.0.2 below that sets the community
+# string to enable write access.
+write := "geheim"
+trap := "mytrap"
+
+#
+# Configuration
+#
+%snmpd
+begemotSnmpdDebugDumpPdus = 2
+begemotSnmpdDebugSyslogPri = 7
+
+#
+# Set the read and write communities.
+#
+# The default value of the community strings is NULL (note, that this is
+# different from the empty string). This disables both read and write access.
+# To enable read access only the read community string must be set. Setting
+# the write community string enables both read and write access with that
+# string.
+#
+# Be sure to understand the security implications of SNMPv2 - the community
+# strings are readable on the wire!
+#
+begemotSnmpdCommunityString.0.1 = $(read)
+# begemotSnmpdCommunityString.0.2 = $(write)
+begemotSnmpdCommunityDisable = 1
+
+# open standard SNMP ports
+begemotSnmpdPortStatus.0.0.0.0.161 = 1
+
+# open a unix domain socket
+begemotSnmpdLocalPortStatus."/var/run/snmpd.sock" = 1
+begemotSnmpdLocalPortType."/var/run/snmpd.sock" = 4
+
+# send traps to the traphost
+begemotTrapSinkStatus.[$(traphost)].$(trapport) = 4
+begemotTrapSinkVersion.[$(traphost)].$(trapport) = 2
+begemotTrapSinkComm.[$(traphost)].$(trapport) = $(trap)
+
+sysContact = $(contact)
+sysLocation = $(location)
+sysObjectId = 1.3.6.1.4.1.12325.1.1.2.1.$(system)
+
+snmpEnableAuthenTraps = 2
+
+#
+# Load MIB-2 module
+#
+begemotSnmpdModulePath."mibII" = "/usr/lib/libsnmp_mibII.so.3.0"
+
+# Force a polling rate for the 64-bit interface counters in case
+# the automatic computation is wrong (which may be the case if an interface
+# announces the wrong bit rate via its MIB).
+#%mibII
+#begemotIfForcePoll = 2000
+
+#
+# Netgraph module
+#
+#begemotSnmpdModulePath."netgraph" = "/usr/lib/snmp_netgraph.so"
+#
+#%netgraph
+#begemotNgControlNodeName = "snmpd"
+
+#
+# pf(4) module
+#
+#begemotSnmpdModulePath."pf" = "/usr/lib/snmp_pf.so"
+
+#
+# Host resources module
+# This requires the mibII module.
+#
+#begemotSnmpdModulePath."hostres" = "/usr/lib/snmp_hostres.so"
+
+#
+# Bridge module
+# This requires the mibII module.
+#
+#begemotSnmpdModulePath."bridge" = "/usr/lib/snmp_bridge.so"
+
diff --git a/net-analyzer/bsnmp/files/werror.patch b/net-analyzer/bsnmp/files/werror.patch
new file mode 100644
index 000000000000..7a0968e84441
--- /dev/null
+++ b/net-analyzer/bsnmp/files/werror.patch
@@ -0,0 +1,11 @@
+--- bsnmp-1.12/config/Makefile.pre.old 2012-04-26 10:45:58.000000000 -0400
++++ bsnmp-1.12/config/Makefile.pre 2012-04-26 10:46:11.000000000 -0400
+@@ -53,7 +53,7 @@
+ # Assume a Posix-ish make that passes MAKEFLAGS in the environment.
+ SUBMAKE= $(MAKE) --no-print-directory
+
+-WARNS= -Wsystem-headers -Werror -Wall -Wno-format-y2k -W \
++WARNS= -Wsystem-headers -Wall -Wno-format-y2k -W \
+ -Wstrict-prototypes -Wmissing-prototypes \
+ -Wpointer-arith -Wreturn-type -Wcast-qual \
+ -Wwrite-strings -Wswitch -Wshadow -Wcast-align \