summaryrefslogtreecommitdiff
path: root/net-analyzer/arpoison
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
commitfd87b7c771378b2116981e3924bee5805148e118 (patch)
tree91ed28393c7b534787d3c073e269fe598d0fd535 /net-analyzer/arpoison
parent77b74be093bdf4a0ed4121acc3f8e229103cf004 (diff)
gentoo auto-resync : 22:11:2023 - 17:18:34
Diffstat (limited to 'net-analyzer/arpoison')
-rw-r--r--net-analyzer/arpoison/Manifest3
-rw-r--r--net-analyzer/arpoison/arpoison-0.7-r1.ebuild28
-rw-r--r--net-analyzer/arpoison/arpoison-0.7.ebuild6
3 files changed, 33 insertions, 4 deletions
diff --git a/net-analyzer/arpoison/Manifest b/net-analyzer/arpoison/Manifest
index 56d9aeedc280..3b437008fb40 100644
--- a/net-analyzer/arpoison/Manifest
+++ b/net-analyzer/arpoison/Manifest
@@ -1,3 +1,4 @@
DIST arpoison-0.7.tar.gz 8458 BLAKE2B b0050aa6f3246fec9fb4db8bbb3f9f5f1d52b5b6c37851f0c6bec8b6c89fabd7f1811ae40a4c81af6eae16761f38fb749d0f2a58311645ef360d798b6ccbbb50 SHA512 d5af078c8e2c64eb721da75b5d6659ca017267f146d0dca7e0f1ba77bfd93a0f56363428c198e9c46537768d3568d813c150bfbc091430fc355a269f9327108f
-EBUILD arpoison-0.7.ebuild 703 BLAKE2B 11b20022bf6f81343f739d43fc3f9b98581d6887cb4fa28d778d51bbe7a740572d5f670e374a6dff7ceae7caf430ab823183ebe1eb884bed5750001a58b159b2 SHA512 1a5cdc0766c1e6e968b0b335ccfe31bd003dcd63d913efab5c22e34ae980cfc082ad9cb8cebc092130bd8839e11a173079287977893fc9c97e7acf008a3bd604
+EBUILD arpoison-0.7-r1.ebuild 657 BLAKE2B 0e770fe307787e555cac69323253ab39933ebde95946c591607236aa55f6e609718d874f4fcd8a6c57dad0d37f6d67c617e37c59788563fed9d48afc5d309105 SHA512 4aa6327061c6ba2d4763b4b15a0393c510911847f6105349d26e3268c81f701bfd48f9a414f17ca90bca2729ac634a416df111a606b292b24fc042790e4fd1eb
+EBUILD arpoison-0.7.ebuild 702 BLAKE2B 501a11ae6f59795dd719fe04e6b92e0701f7646a09d72b2f19a9ebf1ec3f6594561c0352bbf1c8eb3c150fddde8c104f0fffc1f499cb911829f0447c350ef687 SHA512 bcb5e55683d49c1b51e19eceac8b339cbf7ec5785e060bd2f7529fa7fc932f4daa1c8d3bf958adc60549df87924a49d018f8b8cf895f43570a13e3122b3e2908
MISC metadata.xml 359 BLAKE2B a850a908f091a7833a10206ca9ec2ea66bb02830ac93ef1b30aa785c2639e2b772116c2e86efa123fc4a853c5f6505bffb8e4d59ae7c92aea3647a559be97da1 SHA512 d5000b395c3bc2a94e079b30b8e834b4074cf55a0ad4e699545cc46f26135eed5913b749c06afcc82680d7b4defed934a49088c02f0e77233d03e0efe5cea49c
diff --git a/net-analyzer/arpoison/arpoison-0.7-r1.ebuild b/net-analyzer/arpoison/arpoison-0.7-r1.ebuild
new file mode 100644
index 000000000000..b55d86faed1c
--- /dev/null
+++ b/net-analyzer/arpoison/arpoison-0.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs edo
+
+DESCRIPTION="Utility to poison ARP caches"
+HOMEPAGE="https://arpoison.sourceforge.net/ http://www.arpoison.net/"
+SRC_URI="https://dev.gentoo.org/~jsmolic/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~riscv ~x86"
+
+RDEPEND="net-libs/libnet:1.1"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ edo "$(tc-getCC)" "${PN}.c" -o "${PN}" ${CFLAGS} ${LDFLAGS} $("${BROOT}/usr/bin/libnet-config" --cflags --libs)
+}
+
+src_install() {
+ dosbin arpoison
+ doman arpoison.8
+ dodoc README
+}
diff --git a/net-analyzer/arpoison/arpoison-0.7.ebuild b/net-analyzer/arpoison/arpoison-0.7.ebuild
index 625d227a73fc..adb0567ef881 100644
--- a/net-analyzer/arpoison/arpoison-0.7.ebuild
+++ b/net-analyzer/arpoison/arpoison-0.7.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
-DESCRIPTION="A utility to poison ARP caches"
-HOMEPAGE="http://arpoison.sourceforge.net/ http://www.arpoison.net/"
+DESCRIPTION="Utility to poison ARP caches"
+HOMEPAGE="https://arpoison.sourceforge.net/ http://www.arpoison.net/"
SRC_URI="https://dev.gentoo.org/~jsmolic/distfiles/${P}.tar.gz"
LICENSE="GPL-2"