summaryrefslogtreecommitdiff
path: root/net-analyzer/arpoison
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/arpoison
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/arpoison')
-rw-r--r--net-analyzer/arpoison/Manifest5
-rw-r--r--net-analyzer/arpoison/arpoison-0.6-r2.ebuild38
-rw-r--r--net-analyzer/arpoison/metadata.xml11
3 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/arpoison/Manifest b/net-analyzer/arpoison/Manifest
new file mode 100644
index 000000000000..c1505300680a
--- /dev/null
+++ b/net-analyzer/arpoison/Manifest
@@ -0,0 +1,5 @@
+DIST arpoison-0.6.tar.gz 8646 SHA256 2922a7f98901a2eb3b26822e576ef22a64d3585fb69c4c3c4c32c2ca3993e537 SHA512 7c14a15b9b85f777e5151fae82dfbdb44dbfc85ce8f632b7d76727bce79ed7f958f725f39348489bc4659cb5e3b7ab5370e88e33c03277e16ab2f9ff00bb4038 WHIRLPOOL 17fb536d184c60a31d5f07c91da5232763a02c953ea821938f72293500f7f3adae43c1a2e58685852cd3f27803991f31447bce03a1ad71f89b026bae22164bd4
+EBUILD arpoison-0.6-r2.ebuild 777 SHA256 7317790a3d833a34f914cb8a600950948fbee5e34c4ba5cc69d8b909cc15e83d SHA512 91565961d5cf3148236dd4522ac5343e46eb3bc76dda80d8fc5b35b0d9d5a21cfa1c3716207b580a7fde7127b596295cceb7f14a9b52bbbf67afa0d170b988bc WHIRLPOOL bb265ed71e0aa1166561f5fa753a51251966dbd0e5822c2ceada38412a3a7ddeb921890d0fff8b6b71e14fb0b562870f11c6990caaf91650d5c433a813e12548
+MISC ChangeLog 2436 SHA256 34acbbde3d65c58787a60fe904cd599480ba7b450f4936760849d42ad48c381b SHA512 238bc438dc1fe71e89f5f4ffa241b428f68e0df4edc2684465d5695d69ba80dcf8addad1ad78b47e70eb88f9ae97cd6f446ee0d88a594fcdac53e509b90a1fc5 WHIRLPOOL b56f4585b6bb48bde63c3a60ecf3bd0e6bd5b21953b1a233a085c41ae1cc9fb50d8535bf8b7d58bba751cc256fc267b48dd8f0574dc0cb34c0ba4d464af91108
+MISC ChangeLog-2015 2363 SHA256 2c094374328f8dac3b0c0af3bd17038ddd7efbae2d9a22828e07903b57aaf2d3 SHA512 c391405aab45220d8579e2668f7c67a47909abd9e0f1596d263643edd01697e4b4ab249f2e1541d4a85d9c7183124eb304d5a0bf111cc7cf456a295e5d815b34 WHIRLPOOL 25ffcf400607911838feb60ca5178e93dfdc12dfe6f2dfb80be523ef808d2d3e850e81d490ec1bf37cd84639d121e52b65aa85dbd56e2d93ea04fbfd93340bd9
+MISC metadata.xml 358 SHA256 a4d37381c3159fbd9effac3fb203b2e17fb18e7536aceadfbc509f1c19ec7011 SHA512 9a11704d5314e9ab1a061a179e757146b29c52334511578fe958455d417652c0ab523a58a17580ea6892e528d44b06aa8510293664d78ed01f35e32ef1d7bc18 WHIRLPOOL 69315ebedcf70031a60df8b0ecda3cdd48283adb3fa677c382d32f85337447f8fdc0e272542acde157e228f8eb306d3cfe5e8e29b4a1faea12c6726f004447aa
diff --git a/net-analyzer/arpoison/arpoison-0.6-r2.ebuild b/net-analyzer/arpoison/arpoison-0.6-r2.ebuild
new file mode 100644
index 000000000000..628bef5fd8bf
--- /dev/null
+++ b/net-analyzer/arpoison/arpoison-0.6-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A utility to poison ARP caches"
+HOMEPAGE="http://arpoison.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+
+RDEPEND="net-libs/libnet:1.1"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # respect CFLAGS, LDFLAGS and compiler, bug #337896
+ # fix for crosscompilation, bug #375655
+ sed -i Makefile \
+ -e 's|gcc \(-Wall\)|$(CC) \1 $(CFLAGS) $(LDFLAGS)|' \
+ -e "s|libnet-config|${ROOT}usr/bin/libnet-config|g" \
+ || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin arpoison
+ doman arpoison.8
+ dodoc README TODO
+}
diff --git a/net-analyzer/arpoison/metadata.xml b/net-analyzer/arpoison/metadata.xml
new file mode 100644
index 000000000000..22b19a014fbc
--- /dev/null
+++ b/net-analyzer/arpoison/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>netmon@gentoo.org</email>
+ <name>Gentoo network monitoring and analysis project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">arpoison</remote-id>
+ </upstream>
+</pkgmetadata>