summaryrefslogtreecommitdiff
path: root/net-analyzer/arping/arping-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/arping/arping-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/arping/arping-9999.ebuild')
-rw-r--r--net-analyzer/arping/arping-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/arping/arping-9999.ebuild b/net-analyzer/arping/arping-9999.ebuild
new file mode 100644
index 000000000000..252fac54a2de
--- /dev/null
+++ b/net-analyzer/arping/arping-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools fcaps git-r3
+
+DESCRIPTION="ARP Ping"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+EGIT_REPO_URI="https://github.com/ThomasHabets/arping"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS=""
+
+CDEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.1
+"
+DEPEND="
+ ${CDEPEND}
+ dev-libs/check
+"
+RDEPEND="
+ ${CDEPEND}
+ !net-misc/iputils[arping(+)]
+"
+
+FILECAPS=( cap_net_raw /usr/sbin/arping )
+
+src_prepare() {
+ default
+ eautoreconf
+}