summaryrefslogtreecommitdiff
path: root/net-analyzer/arp-scan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 17:52:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 17:52:00 +0100
commitdd851ab76c56a249df7a0ec052acd90940bc014f (patch)
treeb9a0f7262f1fadcf70488c6c3c4dc644b502dc52 /net-analyzer/arp-scan
parent713e25c0c3d1e5434ac60ec0549708ec2f744bb4 (diff)
gentoo auto-resync : 04:10:2023 - 17:51:59
Diffstat (limited to 'net-analyzer/arp-scan')
-rw-r--r--net-analyzer/arp-scan/Manifest4
-rw-r--r--net-analyzer/arp-scan/arp-scan-1.10.0.ebuild34
-rw-r--r--net-analyzer/arp-scan/arp-scan-99999.ebuild26
-rw-r--r--net-analyzer/arp-scan/files/arp-scan-1.10.0-dont-clobber-fortify-source.patch25
4 files changed, 62 insertions, 27 deletions
diff --git a/net-analyzer/arp-scan/Manifest b/net-analyzer/arp-scan/Manifest
index 10063750b966..013939ffe012 100644
--- a/net-analyzer/arp-scan/Manifest
+++ b/net-analyzer/arp-scan/Manifest
@@ -1,4 +1,6 @@
+AUX arp-scan-1.10.0-dont-clobber-fortify-source.patch 871 BLAKE2B 404b917ae7b6443bdb39c87592bcf3291346d3b51d5ac0380280bf0a5a6913fbce955b1eccac31d27412d337ca703557a0add58ddd7b2117fa69e487cda03f72 SHA512 359379ee7ec53ac5b322bfc35e651cb883af73a44ff6f2612f84fbc05abc9186424f1bb8060f7d2614994714242642c570a45c9172083b440e2e50d384b07fe5
+DIST arp-scan-1.10.0.tar.gz 653900 BLAKE2B 618a8201a2c7f425dce5b4260857542956caa4beed61fde9d85cf763076c12ef24eb5a059a5d332b739f1e5b2b3d18db922e6299ff46f7e02ddfb54562b3fc3e SHA512 716c7727597bdecf9fd3f064fe1715148c246c223c2adeb01a26417865e4d82b9ca47e7fe4a555e510e0ae65f23f8310f0dbdffdb7c3fd969e3b81d0c6e4ae2a
DIST arp-scan-1.9.7.tar.gz 459544 BLAKE2B bd70b2dd9e005096ce80fca07b8f2d8482b1073d25a2a9f82e8f5c1206148dbeab095046292cb46b5823aa18b56c208a5e86d0b7252d8566ddee5cd714b78cc6 SHA512 2aa808521a64cd3e2a6a270c6725f2cffa4cfce5c251e5483053c8ea9f56fb1368dd9aae2afcf8fffe1030fe2fc37723f0701c9eafa7cd1d52df459c07a80870
+EBUILD arp-scan-1.10.0.ebuild 651 BLAKE2B 31a7bfca9004014a2fe5bddb8226b80563c8fd73baf1cd0756bca2a7335d8d477d026539ebf6d00592f46fa21607fb517ab0d82a928f3fc100bc9242dadc7c6f SHA512 cea92de94a40305f8f0027438daab0639e374d7f4e02e99fd0d5071d2f90b8adfc38f9318ae3630b9509c109b31889fc4b68a0dfcc423f334e29a99cd6cda9f5
EBUILD arp-scan-1.9.7.ebuild 496 BLAKE2B 2a33868209b807025802dfffaf17fd3e3c219a914e2aee2ea974ee4328f62b63671c19857de5d5f76ac9ee88e1486f257b2f00e8b87a74679264af496ec1ff1a SHA512 30bd6aca39bf48ea57e5ce208ed7b6293b4f40ae4f81b149a4636343a161ac7ad5f4086a7820f32b30bdd166ea9168691a58ab8f31b8270bd50e6d9a30049f82
-EBUILD arp-scan-99999.ebuild 437 BLAKE2B 7a306bfc3b31f3da8e1d5974fc50f90e32f3f01d766cbcc7f9b9408347a37a771da8f83df3a8fd0dcffe5ab80528927e5876f584e08361644a282e445c4f7bfe SHA512 eb8d8ac754ec26d4c122586596a649afee8f9de1a701ee36d24838a37dd3f6256a5820c818c8fdcda171eeacc29dbda8e03778b92a300c6b1ee31c7820e467b0
MISC metadata.xml 363 BLAKE2B 779a9cd3cba88ae4076ed6b094efbfeb4433e81c757bde0555e87afc9562c64f1575503a7b1395e9e41b9e659a5037bbb124ea38abde3193d9ac001a7ddea2f4 SHA512 864d8e4092af38e8fb45652cf17259466d94dd810707c2c39f7d5115dcaa1adc0164eb8397e7e303d1b57559946cc79941fd137e0a0a54cb71227196de2e95fc
diff --git a/net-analyzer/arp-scan/arp-scan-1.10.0.ebuild b/net-analyzer/arp-scan/arp-scan-1.10.0.ebuild
new file mode 100644
index 000000000000..7ab46fd66b97
--- /dev/null
+++ b/net-analyzer/arp-scan/arp-scan-1.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="ARP scanning and fingerprinting tool"
+HOMEPAGE="https://github.com/royhills/arp-scan"
+SRC_URI="https://github.com/royhills/arp-scan/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/libcap
+"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+# Needed for _F_S patch
+BDEPEND="sys-devel/autoconf-archive"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10.0-dont-clobber-fortify-source.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
diff --git a/net-analyzer/arp-scan/arp-scan-99999.ebuild b/net-analyzer/arp-scan/arp-scan-99999.ebuild
deleted file mode 100644
index c0d127582510..000000000000
--- a/net-analyzer/arp-scan/arp-scan-99999.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools git-r3
-
-DESCRIPTION="ARP scanning and fingerprinting tool"
-HOMEPAGE="https://github.com/royhills/arp-scan"
-EGIT_REPO_URI="https://github.com/royhills/arp-scan"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS=""
-
-DEPEND="
- net-libs/libpcap
-"
-RDEPEND="
- ${DEPEND}
- dev-lang/perl
-"
-
-src_prepare() {
- default
- eautoreconf
-}
diff --git a/net-analyzer/arp-scan/files/arp-scan-1.10.0-dont-clobber-fortify-source.patch b/net-analyzer/arp-scan/files/arp-scan-1.10.0-dont-clobber-fortify-source.patch
new file mode 100644
index 000000000000..f933e965893b
--- /dev/null
+++ b/net-analyzer/arp-scan/files/arp-scan-1.10.0-dont-clobber-fortify-source.patch
@@ -0,0 +1,25 @@
+Don't clobber toolchain defaults.
+
+(TODO: Fix upstream's GCC_FORTIFY_SOURCE macro or just replace it with the
+autoconf-archive one (AX_ADD_FORTIFY_SOURCE)).
+
+https://bugs.gentoo.org/895522
+--- a/configure.ac
++++ b/configure.ac
+@@ -37,7 +37,6 @@ if test -n "$GCC"; then
+ CFLAGS="$CFLAGS -Wall -Wshadow -Wwrite-strings"
+ GCC_WEXTRA
+ GCC_STACK_PROTECT_CC
+- GCC_FORTIFY_SOURCE
+ GCC_FORMAT_SECURITY
+ dnl Uncomment the line below to compile with additional warnings enabled.
+ dnl CFLAGS="$CFLAGS -pedantic -Wpointer-arith -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs"
+@@ -49,6 +48,8 @@ else
+ fi
+ AC_PROG_INSTALL
+
++AX_ADD_FORTIFY_SOURCE
++
+ dnl Checks for libraries.
+ dnl Solaris 10 needs -lnsl for gethostbyname() and -lsocket for socket().
+ dnl Linux, {Free,Open,Net,Dragonfly}BSD and MacOS X do not.