summaryrefslogtreecommitdiff
path: root/net-analyzer/apinger/apinger-0.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /net-analyzer/apinger/apinger-0.6.1.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'net-analyzer/apinger/apinger-0.6.1.ebuild')
-rw-r--r--net-analyzer/apinger/apinger-0.6.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/apinger/apinger-0.6.1.ebuild b/net-analyzer/apinger/apinger-0.6.1.ebuild
new file mode 100644
index 000000000000..46661a8ba3e7
--- /dev/null
+++ b/net-analyzer/apinger/apinger-0.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Alarm Pinger"
+HOMEPAGE="https://github.com/Jajcus/apinger/"
+SRC_URI="
+ https://dev.gentoo.org/~jer/${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ sys-devel/flex
+ virtual/yacc
+"
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.1-fno-common.patch
+ "${FILESDIR}"/${PN}-0.4.1-stray-backslash.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake -C src/ cfgparser1.h
+ default
+}
+
+src_install() {
+ default
+ insinto /etc
+ doins src/${PN}.conf
+}