summaryrefslogtreecommitdiff
path: root/net-analyzer/angst/angst-0.4b-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/angst/angst-0.4b-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/angst/angst-0.4b-r2.ebuild')
-rw-r--r--net-analyzer/angst/angst-0.4b-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/angst/angst-0.4b-r2.ebuild b/net-analyzer/angst/angst-0.4b-r2.ebuild
new file mode 100644
index 000000000000..f06986f35421
--- /dev/null
+++ b/net-analyzer/angst/angst-0.4b-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="an active sniffer that provides methods for aggressive sniffing on switched LANs"
+HOMEPAGE="http://angst.sourceforge.net/"
+SRC_URI="http://angst.sourceforge.net/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+DEPEND="net-libs/libpcap
+ net-libs/libnet:1.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp -av Makefile.linux{,.orig}
+ epatch "${FILESDIR}"/${PV}-libnet-1.0.patch
+ sed -i Makefile.linux \
+ -e 's|^CC =|CC ?=|g' \
+ -e '/ -o angst /s|$(OBJS)|$(LDFLAGS) &|g' \
+ || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ -f Makefile.linux
+}
+
+src_install() {
+ dosbin angst
+ doman angst.8
+ dodoc README TODO ChangeLog
+}