summaryrefslogtreecommitdiff
path: root/media-video
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-07 18:30:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-07 18:30:54 +0100
commit4d190a87291ace8503ad92c6b049d14660a14c72 (patch)
tree3c46c3d158d4e77a4c12d283a17bade041a9859f /media-video
parent3c7931f8c6c90aa813912d87c684d742e0c29a05 (diff)
gentoo auto-resync : 07:04:2024 - 18:30:54
Diffstat (limited to 'media-video')
-rw-r--r--media-video/Manifest.gzbin24541 -> 24543 bytes
-rw-r--r--media-video/gaupol/Manifest2
-rw-r--r--media-video/gaupol/gaupol-1.14.1.ebuild69
3 files changed, 71 insertions, 0 deletions
diff --git a/media-video/Manifest.gz b/media-video/Manifest.gz
index a5beb9be9336..c6f044a7ada0 100644
--- a/media-video/Manifest.gz
+++ b/media-video/Manifest.gz
Binary files differ
diff --git a/media-video/gaupol/Manifest b/media-video/gaupol/Manifest
index ff293663fe16..39647d407973 100644
--- a/media-video/gaupol/Manifest
+++ b/media-video/gaupol/Manifest
@@ -1,4 +1,6 @@
AUX gaupol-1.12-fix-prefix.patch 1266 BLAKE2B 0d2c5ae5cb76099f9e91e78e3a7d3c1b1bec73c223a4c5dfcb407a6efd60f42b4d9174faba318005400f2df346929baee5224ebc2d0b6b8f23a868a6f5451b0c SHA512 1d56b2793821a19d3dddb95c7c3a52e2f1e6af54886f77862cde1b3e7585b60990b1a8a61b4056b4676bce4ce722dc77ce0bd1116668118c8f4168884260da6e
DIST gaupol-1.13.tar.gz 592830 BLAKE2B dcde1dd6c5e3e9624f0e7692c4d6cc14452733d1e35bc25de5deaa842cdb069250dee0b2d9eb75d1bb9f3c618c43457718ce91f5a6992ec7797fbb37366fc524 SHA512 ebe2accd962344c07201e46ceff3801483a4c68f9772d1fc868a93d8044b65987f7233eab675a9f3148bce686261a6b5c40d66d3f9471f9515713fbfb46a3f92
+DIST gaupol-1.14.1.tar.gz 593435 BLAKE2B f7ee1f2e70707f54204400d99107a1ee62b721e7ee0be76ce980a261b1b95349aefcc5907dc5cf956fd703a4372065576371cdf0466a32ee206d797b1500d53d SHA512 efaa9910496dcd683be40ff33bf68de313b852d6212f3f43c67e6433eb3b95b64c89707d1a69a54c9f772c44cf04f95ca76d705d396b376ac1c86c4bbe48e4e0
EBUILD gaupol-1.13.ebuild 1704 BLAKE2B c093232a478ae38556b91f01f0f47d7fc194e656436ac300c2b9942c51ff03d70f3a69f01342b1d2785c30a3849052f46694642c6bddb9ff71282228a3eb9e8c SHA512 52f9cffea16ccdda7098cf1a2fa9562635b5bc7b0f95f80d500a9c47d37838df208adbbf8d01f694bd3491c1ae9692eabf21a96071b9d95f38f3c83092bdfc32
+EBUILD gaupol-1.14.1.ebuild 1707 BLAKE2B 3f264cf5876f186ea05b500df2df8c38ee51fb8d8cef0245b28036e21e820216d7d8862fc4436a9ab90ec5c9e086a1a161c53880d6702b8b9a84f2303750554b SHA512 da2bfee4e91e69e1b5a06f17fccca31a5a2093472c2e7666895a01c072cb45b5a6d6ec522b8ef65194d536eda589b2585a117427369742f848704539072f3593
MISC metadata.xml 533 BLAKE2B eb6d56dbe104832c594f306fc020b591b04e4f21d7533740ab613ecf105cdfdc4bc9232fe18bbfc4276cc08063a7a570a1c98025e9c74561b4abda0119e3801e SHA512 49859f8f6b75f20c6cf94f60764c1e688ddf907a7657815574b666fcc7873de0a3105cda9acd9f4bbdb7f658bd0003c67ec1ced72e3d84e15b5d86b64ca91abe
diff --git a/media-video/gaupol/gaupol-1.14.1.ebuild b/media-video/gaupol/gaupol-1.14.1.ebuild
new file mode 100644
index 000000000000..0caa08c6a2f9
--- /dev/null
+++ b/media-video/gaupol/gaupol-1.14.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="A subtitle editor for text-based subtitles"
+HOMEPAGE="https://otsaloma.io/gaupol/ https://github.com/otsaloma/gaupol/"
+SRC_URI="https://github.com/otsaloma/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="spell"
+
+RDEPEND="
+ app-text/iso-codes
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ spell? ( app-text/gspell[introspection] )
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ app-dicts/myspell-en
+ app-text/enchant[hunspell]
+ app-text/gspell[introspection]
+ )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.md NEWS.md README.md README.aeidon.md )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.12-fix-prefix.patch"
+)
+
+python_test() {
+ virtx epytest
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "The integrated video player requires media-plugins/gst-plugins-gtk."
+ elog ""
+ elog "External video previewing support requires MPV, MPlayer or VLC."
+ if use spell; then
+ elog ""
+ elog "Spell-checking requires a dictionary, any of app-dicts/myspell-*"
+ elog "or app-text/aspell with the appropriate L10N variable."
+ elog ""
+ elog "Additionally, make sure that app-text/enchant has the correct flags enabled:"
+ elog "USE=hunspell for myspell dictionaries and USE=aspell for aspell dictionaries."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}